Bug 1315965 - Number of packages in repo are not updated after incremental import
Number of packages in repo are not updated after incremental import
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: Chris Duryee
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On: 1314299
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 02:24 EST by Jitendra Yejare
Modified: 2016-07-27 05:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:26:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14109 None None None 2016-04-22 10:54 EDT

  None (edit)
Description Jitendra Yejare 2016-03-09 02:24:40 EST
Description of problem:
Number of packages after incremental import are not updated or else the incremental import doesnt seems to be functional.

The output says 100 % completed and no error in bg logs but still the number of packages are not updated or else the result is false.

Version-Release number of selected component (if applicable):
Satellite 6.2 snap 2.1

How reproducible:


Steps to Reproduce:
1. From upstream satellite, Export incremental repo.
2. Copy the exported repo contents to /var/www/html
3. Use the step 2 location with file:///<location> to perform incremental import in downstream org/satellite.

Actual results:
The output says 100 % completed and no error in bg logs but still the number of packages are not updated or else the result is false.

Expected results:
The number of packages updated after incremental repo import or incremental import works.

Additional info:
Comment 2 Chris Duryee 2016-03-09 19:02:47 EST
Incremental import was broken, I was calling a dynflow task using old parameters that had since been updated.
Comment 3 Bryan Kearney 2016-03-09 20:01:48 EST
Upstream bug component is Content Management
Comment 4 Bryan Kearney 2016-03-10 14:01:51 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/14109 has been closed
-------------
Chris Duryee
Applied in changeset commit:katello|e2c0a70723503e77740f914c1d0ac71fbf8ea3a9.
Comment 5 Jitendra Yejare 2016-03-22 09:49:12 EDT
Verified this bug in Sat 6.2 snap 4.

This issue is no more reproducible.

I am able to import the repo incrementally with file:///<location> and the number of packages were updated successfully.

So, changing the status to Verified.
Comment 8 errata-xmlrpc 2016-07-27 05:26:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.