Bug 131597 - lvm2 is missing e2fsadm
lvm2 is missing e2fsadm
Status: CLOSED DUPLICATE of bug 117316
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-02 12:57 EDT by Steven Pritchard
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Pritchard 2004-09-02 12:57:16 EDT
The lvm2 package doesn't contain /sbin/e2fsadm.  (The lvm package
contained this in FC1.)
Comment 1 Alasdair Kergon 2004-09-02 13:11:17 EDT
e2fsadm is obsolete.

The --resizefs option to lvextend/lvreduce/lvresize replaces it, but
this option isn't enabled yet because it needs people to test it first.

[To test it, get LVM2 from CVS and configure --enable-fsadm, reporting
findings to the linux-lvm mailing list.]
Comment 2 Steven Pritchard 2004-09-02 14:13:58 EDT
I would like to (politely :) suggest that

  a) --enable-fsadm be turned on in rawhide (if it isn't already)
  b) a new e2fsadm (or just fsadm) be added, simply for backwards
compatibility with lvm1 and HP-UX's LVM tools
Comment 3 Steven Pritchard 2004-09-02 14:18:54 EDT
On b), I'd be willing to write such a wrapper, if necessary.

The former HP-UX admins at a large company I used to work for (who I
believe is a RHEL customer) will miss it.
Comment 4 Alasdair Kergon 2004-09-02 15:09:58 EDT
(a) Not until it's been tested properly.  Its purpose is to *reduce*
the risk of people making mistakes with resizing, not to add to the
risk of losing a filesystem:-)

(b) e2fsadm can be made an alias for 'lvresize -r' within lvm but I'm
reluctant to put the link in the filesystem as I find the name quite
misleading - it isn't part of the ext2 tools.  What does the name
mean?  ext2 filesystem administration?  Yet it's manipulating a
logical volume and only lets you change the size of the filesystem.
Comment 5 Alexandre Oliva 2004-09-07 13:07:40 EDT

*** This bug has been marked as a duplicate of 117316 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:05:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.