Bug 1315972 - Network flow , ports for patching and provisioning activities on satellite 6
Network flow , ports for patching and provisioning activities on satellite 6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Documentation (Show other bugs)
6.1.5
All Linux
medium Severity medium (vote)
: GA
: 6.2
Assigned To: Stephen Wadeley
Russell Dickenson
:
: 1324157 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 02:43 EST by Komal
Modified: 2016-06-17 10:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-17 00:55:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2177821 None None None 2016-03-09 03:23 EST

  None (edit)
Comment 7 Taft Sanders 2016-05-30 18:41:51 EDT
*** Bug 1324157 has been marked as a duplicate of this bug. ***
Comment 17 Andrew Dahms 2016-06-17 00:55:34 EDT
This content is now live on the Customer Portal.

Closing.
Comment 19 Stephen Wadeley 2016-06-17 10:12:14 EDT
Hello

The tables have been updated and can be found in the "Ports and Firewalls Requirements" section[1]. (There were some that were missing too, and for that we apologize).


Note that in the "Optional Network Ports" table we have made the wording more consistent and we hope it is now clear what ports are used for provisioning. If required, we could split the optional port table up into smaller tables.


TCP is bi-directional by design and UDP is not. 

For TCP, if you have a stateful firewall, you just open in the outgoing direction. I you have a non-stateful firewall, you will have to enable the return path. We believe that as long as the direction is clear from the tables in the installation guide, then the firewall admin should be able to work this out. That is the purpose of the *per-direction* tables, to provide the info required to plan what network based firewall changes are required. We are preparing a diagram to show these paths.

The only UDP communications in the tables are those used by TFTP and DHCP during provisioning. 

TFTP does send UDP packets in both directions, but the traffic is only initiated by the client, from a random port, and the destination port is 69 (server side). 

The DHCP service uses broadcast UDP packets. Port 67 is source *and* destination for the server and the client sends *and* receives on 68. You can think of that as bi-directional I suppose as the ports are known on both sides (no random source port in this case). We hope this is now clear in the "Optional Network Ports" table.


Please let us know if the information is now more intelligible. 

Thank you


[1] https://access.redhat.com/documentation/en/red-hat-satellite/6.2-beta/installation-guide/chapter-2-preparing-your-environment-for-installation#ports_prerequisites

Note You need to log in before you can comment on or make changes to this bug.