Bug 1316012 - tempest.api.object_storage.test_object_version.ContainerTest.test_versioned_container fails due miss-configuration in swift-container
tempest.api.object_storage.test_object_version.ContainerTest.test_versioned_c...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
low Severity low
: ---
: 12.0 (Pike)
Assigned To: Christian Schwede (cschwede)
Martin Kopec
: Automation, AutomationBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 04:07 EST by Arx Cruz
Modified: 2017-05-29 10:00 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-29 10:00:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arx Cruz 2016-03-09 04:07:39 EST
Description of problem:
tempest.api.object_storage.test_object_version.ContainerTest.test_versioned_container fails because /etc/swift/container-server.conf is miss configured

Version-Release number of selected component (if applicable):

openstack-swift-plugin-swift3-1.9-1.el7ost.noarch
openstack-swift-container-2.5.0-2.el7ost.noarch
openstack-swift-account-2.5.0-2.el7ost.noarch
openstack-swift-object-2.5.0-2.el7ost.noarch
openstack-swift-2.5.0-2.el7ost.noarch
openstack-swift-proxy-2.5.0-2.el7ost.noarch
python-swiftclient-2.6.0-1.el7ost.noarch


How reproducible:
All the time

Steps to Reproduce:
1. Install OSP-D
2. Run tempest

Actual results:
tempest.api.object_storage.test_object_version.ContainerTest.test_versioned_container fails

Expected results:
tempest.api.object_storage.test_object_version.ContainerTest.test_versioned_container pass

Additional info:
It's possible to fix it editing /etc/swift/container-server.conf setting allow_versions option to true and restarting the service:

crudini --set /etc/swift/container-server.conf DEFAULT allow_versions true
systemctl restart openstack-swift-container*
Comment 2 Mike Burns 2016-04-07 17:14:44 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 4 Attila Fazekas 2017-04-03 11:42:18 EDT
Since 10 it does not fails, also the recommended configuration is different since 10.
Comment 5 Fabio Massimo Di Nitto 2017-05-18 11:22:57 EDT
Paul,

this bug appears to be Storage related. Could you please have your guys check that the relative tempest test is now working as expected?
Comment 6 Paul Grist 2017-05-18 11:49:25 EDT
Will take a look, but also sounds like it's not an issue anymore based on #c4? Not sure there is a a reason to keep it open, but let's see if we want to make a default change or to expose an option.  But this seems to be passing and it also had a work around.
Comment 7 Christian Schwede (cschwede) 2017-05-29 10:00:49 EDT
This one does not affect OSP10 and later; the versioning architecture has been changed in Newton and no longer requires the setting in the container server.

Closing this bug therefore; please re-open if this is still an issue.

Note You need to log in before you can comment on or make changes to this bug.