This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1316016 - Glance telemetry notification is failing
Glance telemetry notification is failing
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 10.0 (Newton)
Assigned To: Pradeep Kilambi
Arx Cruz
: Automation, AutomationBlocker, Triaged
Depends On:
Blocks: 1335596 1356451
  Show dependency treegraph
 
Reported: 2016-03-09 04:25 EST by Arx Cruz
Modified: 2016-12-14 10:28 EST (History)
15 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.5.0rc3.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, Telemetry (ceilometer) notifications would fail due to missing messaging configuration in Image Service (glance). Consequently, glance notifications failed to be processed. With this update, the tripleo templates have been amended to add the correct configuration. As a result, glance notifications are now processed correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-14 10:28:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 384481 None None None 2016-10-10 08:48 EDT
OpenStack gerrit 386011 None None None 2016-10-14 16:04 EDT

  None (edit)
Description Arx Cruz 2016-03-09 04:25:48 EST
Description of problem:
Glance telemetry notification api is failing due the miss configure config file

Version-Release number of selected component (if applicable):
python-glanceclient-1.1.0-1.el7ost.noarch
python-glance-11.0.1-3.el7ost.noarch
python-glance-store-0.9.1-1.el7ost.noarch
openstack-glance-11.0.1-3.el7ost.noarch
openstack-ceilometer-collector-5.0.2-2.el7ost.noarch
python-ceilometerclient-1.5.2-1.el7ost.noarch
python-ceilometer-5.0.2-2.el7ost.noarch
openstack-ceilometer-api-5.0.2-2.el7ost.noarch
openstack-ceilometer-compute-5.0.2-2.el7ost.noarch
python-ceilometermiddleware-0.3.0-1.el7ost.noarch
openstack-ceilometer-common-5.0.2-2.el7ost.noarch
openstack-ceilometer-polling-5.0.2-2.el7ost.noarch
openstack-ceilometer-notification-5.0.2-2.el7ost.noarch
openstack-ceilometer-alarm-5.0.2-2.el7ost.noarch
openstack-ceilometer-central-5.0.2-2.el7ost.noarch


How reproducible:


Steps to Reproduce:
1. Install OSP-D
2. Run tempest

Actual results:
tempest.api.telemetry.test_telemetry_notification_api.TelemetryNotificationAPITestJSON.test_check_glance_v1_notifications 

Fails

Expected results:
tempest.api.telemetry.test_telemetry_notification_api.TelemetryNotificationAPITestJSON.test_check_glance_v1_notifications

Pass

Additional info:
To fix it, you need to edit /etc/glance/glance-api.conf and set the rabbit_hosts and notification_driver options properly:
 
crudini --set /etc/glance/glance-api.conf oslo_messaging_rabbit rabbit_hosts IP_RABBIT_DAEMON
crudini --set /etc/glance/glance-api.conf DEFAULT notification_driver messagingv2

And restart the services:

systemctl restart openstack-ceilometer-alarm-notifier.service openstack-ceilometer-api.service openstack-ceilometer-collector.service openstack-ceilometer-notification.service openstack-ceilometer-polling.service openstack-ceilometer-alarm-evaluator.service
systemctl restart openstack-glance-api openstack-glance-registry
Comment 2 Mike Burns 2016-04-07 17:14:44 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 6 Julien Danjou 2016-10-21 11:45:27 EDT
/etc/glance/glance-*.conf on OSP 10 shows:

#
# From oslo.messaging
#

# The Drivers(s) to handle sending notifications. Possible values are messaging,
# messagingv2, routing, log, test, noop (multi valued)
# Deprecated group/name - [DEFAULT]/notification_driver
#driver =

# A URL representing the messaging driver to use for notifications. If not set,
# we fall back to the same configuration used for RPC. (string value)
# Deprecated group/name - [DEFAULT]/notification_transport_url
#transport_url = <None>

# AMQP topic used for OpenStack notifications. (list value)
# Deprecated group/name - [rpc_notifier2]/topics
# Deprecated group/name - [DEFAULT]/notification_topics
#topics = notifications


Those options seems unset, so it's likely that it does not work.
Comment 9 Yurii Prokulevych 2016-11-22 09:56:52 EST
Verified with openstack-tripleo-heat-templates-5.1.0-3.el7ost.noarch

[root@controller-1 ~]# grep ^driver /etc/glance/glance-*conf
/etc/glance/glance-api.conf:driver =messagingv2
/etc/glance/glance-registry.conf:driver =messagingv2

[root@controller-1 ~]# grep ^rabbit /etc/glance/glance-*conf
/etc/glance/glance-api.conf:rabbit_hosts = 172.17.1.10:5672,172.17.1.11:5672,172.17.1.17:5672
/etc/glance/glance-api.conf:rabbit_use_ssl = False
/etc/glance/glance-api.conf:rabbit_userid = guest
/etc/glance/glance-api.conf:rabbit_password = fg4EgsNqzNCzpMMy3TchmX2Fr
/etc/glance/glance-api.conf:rabbit_ha_queues = True
/etc/glance/glance-registry.conf:rabbit_hosts = 172.17.1.10:5672,172.17.1.11:5672,172.17.1.17:5672
/etc/glance/glance-registry.conf:rabbit_use_ssl = False
/etc/glance/glance-registry.conf:rabbit_userid = guest
/etc/glance/glance-registry.conf:rabbit_password = fg4EgsNqzNCzpMMy3TchmX2Fr
/etc/glance/glance-registry.conf:rabbit_ha_queues = True
Comment 11 errata-xmlrpc 2016-12-14 10:28:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.