Bug 1316019 - DNS2 variable is ignored in ifup-post script
DNS2 variable is ignored in ifup-post script
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts (Show other bugs)
7.2
All Linux
unspecified Severity low
: rc
: ---
Assigned To: initscripts Maintenance Team
Leos Pol
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 04:32 EST by Sven Hoexter
Modified: 2016-11-25 08:03 EST (History)
3 users (show)

See Also:
Fixed In Version: initscripts-9.49.31-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:43:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sven Hoexter 2016-03-09 04:32:40 EST
Description of problem:
According to what I see in the ifup-post script changes in the "DNS2" variable are ignored.

As far as I can see in the upstream fedora repository Lukas already commited
a fix in da08727f3bbcc419096b160968aee83104bb7cf6

https://git.fedorahosted.org/cgit/initscripts.git/commit/?id=da08727f3bbcc419096b160968aee83104bb7cf6

Version-Release number of selected component (if applicable):
As far as I can see that bug is present in all 6.x and 7.x releases.
Comment 5 Lukáš Nykrýn 2016-08-08 10:56:27 EDT
*** Bug 1364895 has been marked as a duplicate of this bug. ***
Comment 6 Leos Pol 2016-09-20 10:20:35 EDT
With initscripts-9.49.37-1.el7 I've:
ONBOOT=yes
TYPE=Ethernet
BOOTPROTO=dhcp
DEVICE=eth0
DNS2=8.8.4.4
PEERDNS=yes

then /etc/resolv.conf contains:
nameserver 8.8.4.4
Comment 8 errata-xmlrpc 2016-11-04 02:43:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2456.html

Note You need to log in before you can comment on or make changes to this bug.