Bug 1316034 - pypy update to 4.0.1
Summary: pypy update to 4.0.1
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: pypy
Version: el6
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Michal Cyprian
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-09 09:56 UTC by Anand Buddhdev
Modified: 2016-08-30 01:47 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-08-30 01:47:39 UTC


Attachments (Terms of Use)

Description Anand Buddhdev 2016-03-09 09:56:08 UTC
Description of problem:

The pypy version in EPEL is outdated. Any chance the maintainers could update it to 4.0.1 please?

Version-Release number of selected component (if applicable):

2.0.2-1

How reproducible:

Always

Steps to Reproduce:


Actual results:


Expected results:


Additional info:

Comment 1 Fedora Update System 2016-03-30 08:43:52 UTC
pypy-5.0.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-bfc9ab17ed

Comment 2 Fedora Update System 2016-03-31 02:20:35 UTC
pypy-5.0.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-bfc9ab17ed

Comment 3 Fedora Update System 2016-04-15 05:57:33 UTC
pypy-5.0.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 4 Anand Buddhdev 2016-04-15 08:47:39 UTC
Thank you for this update! Any chance you can also update EPEL 6? I had original hoped for this to go into EPEL 6 first, because pypy also provides Python 2.7, and this is good for CentOS 6 because it only has python 2.6 in the base.

Comment 5 Anand Buddhdev 2016-06-06 11:05:25 UTC
Any chance you can also update EPEL 6? I had original hoped for this to go into EPEL 6 first, because pypy also provides Python 2.7, and this is good for CentOS 6 because it only has python 2.6 in the base.

Comment 6 Michal Cyprian 2016-06-07 15:24:18 UTC
I've started to work on the spec file for EPEL 6 again. It is a bit problematic. There was a lot of changes in PyPy's build scripts and they are Python 2.6 incompatible in  versions >= 4.0.1 . I will hopefully push the update during this or the following week.

Comment 7 Fedora Update System 2016-06-13 15:07:56 UTC
pypy-5.0.1-3.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-43eb0ce9f0

Comment 8 Fedora Update System 2016-06-15 05:17:56 UTC
pypy-5.0.1-3.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-43eb0ce9f0

Comment 9 Anand Buddhdev 2016-06-17 11:06:07 UTC
I have found a show-stopper bug with this update. I'm not sure how to address it, or which package is as fault, but here's the problem:

On a system where I have pypy-2.0.2 installed, and I create a virtualenv to use it, all the links in the virtualenv refer to a path containing the 2.0.2 version. for example:

$ ls -l /opt/virtualenv/lib-python/2.7 | head
total 328
lrwxrwxrwx 1 root root    47 Oct 28  2015 _abcoll.py -> /usr/lib64/pypy-2.0.2/lib-python/2.7/_abcoll.py
lrwxrwxrwx 1 root root    43 Oct 28  2015 abc.py -> /usr/lib64/pypy-2.0.2/lib-python/2.7/abc.py

Now, if I do "yum update pypy" from EPEL testing, then /usr/lib64/pypy-2.0.2 no longer exists, and that virtualenv installation will break immediately. I would have to fix it by recreating the virtualenv, but then it breaks again, if pypy is updated.

I don't know if this is a virtualenv problem, or whether pypy should be packaged without the version in its library path. But it *is* a problem.

Any idea how this can be resolved without breaking pypy virtualenvs?

Comment 10 Fedora Update System 2016-06-30 22:51:48 UTC
pypy-5.0.1-4.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d0e444c5f2

Comment 11 Fedora Update System 2016-07-02 20:17:17 UTC
pypy-5.0.1-4.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d0e444c5f2

Comment 12 Fedora Update System 2016-08-10 07:43:38 UTC
pypy-2.0.2-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d247a6033f

Comment 13 Fedora Update System 2016-08-11 14:16:21 UTC
pypy-2.0.2-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d247a6033f

Comment 14 Michal Cyprian 2016-08-12 07:34:03 UTC
We've decided to revert the update. Problem with virtualenvs have been reported twice. Update like this is probably too big step forward for EPEL 6 branch and the maintenance of this package would be difficult as well.

Comment 15 Anand Buddhdev 2016-08-12 07:58:28 UTC
Hello Michal,

The core of the problem is that the pypy RPMs, for both CentOS 6 and CentOS 7, have been incorrectly packaged from the start. Specifically, the pypy-libs subpackage places all the files in a directory tied to the version of pypy, like this:

/usr/lib64/pypy-5.0.1

When creating a virtualenv, it gets symlinked to this directory. As a result, ANY upgrade of pypy-libs to a new version will break any virtualenv.

Can you guys think of a way to upgrade pypy and fix this core problem? In other words, can you please repackage pypy-libs to place its files into:

/usr/lib64/pypy

This way, upgrading pypy shouldn't break any virtualenvs.

Comment 16 Anand Buddhdev 2016-08-16 15:11:50 UTC
Hello guys. Could one of you please acknowledge that you understand the problem with the currently packaged version of pypy? Then we can discuss possible solutions going forward.

Comment 17 Michal Cyprian 2016-08-19 13:48:38 UTC
Hello,

I am afraid it is a bit more complicated. The change you proposed would probably prevent breaking of virtualenvs. In the other hand it would be for example impossible to install 2 different versions of pypy to the system. 
There is a lot of work to be done and updating of epel packages is not the priority. If you really need this update for some purpose you can create a patch and send it to us.

Comment 18 Fedora Update System 2016-08-30 01:47:36 UTC
pypy-2.0.2-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.