Bug 1316046 - test_volume_boot_pattern and test_rescued_vm_detach_volume fails with rbd driver
test_volume_boot_pattern and test_rescued_vm_detach_volume fails with rbd driver
Status: CLOSED UPSTREAM
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 9.0 (Mitaka)
Assigned To: Jon Bernard
nlevinki
: Automation, AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 05:21 EST by Arx Cruz
Modified: 2016-07-31 21:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-04 07:51:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1554045 None None None 2016-03-09 05:21 EST

  None (edit)
Description Arx Cruz 2016-03-09 05:21:16 EST
Description of problem:
Sometimes for rbd Tempest scenario test_volume_boot_pattern.TestVolumeBootPatternV2.test_volume_boot_pattern fails with following error

2016-02-22 21:46:55.983 23489 WARNING cinder.volume.drivers.rbd [req-9ae2daa0-8df2-44fa-941f-9590ab8fae85 3c43fc722be1439dbdbc6487f468a924 18dad7f31d074553ab095fdf7cc7ce4e - - -] ImageBusy error raised while deleting rbd volume. This may have been caused by a connection from a client that has crashed and, if so, may be resolved by retrying the delete after 30 seconds has elapsed.

2016-02-22 21:46:55.989 23489 ERROR cinder.volume.manager [req-9ae2daa0-8df2-44fa-941f-9590ab8fae85 3c43fc722be1439dbdbc6487f468a924 18dad7f31d074553ab095fdf7cc7ce4e - - -] Unable to delete busy volume.

Version-Release number of selected component (if applicable):
openstack-cinder-7.0.1-6.el7ost.noarch
python-cinderclient-1.5.0-1.el7ost.noarch
python-cinder-7.0.1-6.el7ost.noarch


How reproducible:

Steps to Reproduce:
1. Instal osp with cinder version above
2. Run tempest

Actual results:
tempest.scenario.test_volume_boot_pattern.TestVolumeBootPattern.test_volume_boot_pattern
tempest.scenario.test_volume_boot_pattern.TestVolumeBootPatternV2.test_volume_boot_pattern
tempest.api.compute.servers.test_server_rescue_negative.ServerRescueNegativeTestJSON.test_rescued_vm_detach_volume

Fails

Expected results:
tempest.scenario.test_volume_boot_pattern.TestVolumeBootPattern.test_volume_boot_pattern
tempest.scenario.test_volume_boot_pattern.TestVolumeBootPatternV2.test_volume_boot_pattern
tempest.api.compute.servers.test_server_rescue_negative.ServerRescueNegativeTestJSON.test_rescued_vm_detach_volume

Pass

Additional info:
The launchpad bug attached fix tempest.scenario.test_volume_boot_pattern.TestVolumeBootPattern.test_volume_boot_pattern and tempest.scenario.test_volume_boot_pattern.TestVolumeBootPatternV2.test_volume_boot_pattern

However, the tempest.api.compute.servers.test_server_rescue_negative.ServerRescueNegativeTestJSON.test_rescued_vm_detach_volume still fails with the same error.

Note You need to log in before you can comment on or make changes to this bug.