Bug 1316088 - Two same dialog windows to format DASD disks with CDL
Two same dialog windows to format DASD disks with CDL
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
s390x Linux
medium Severity medium
: rc
: 7.3
Assigned To: Samantha N. Bueno
Release Test Team
:
Depends On:
Blocks: 1256306
  Show dependency treegraph
 
Reported: 2016-03-09 06:47 EST by Jan Stodola
Modified: 2017-03-14 14:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.67-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:23:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2016-03-09 06:47:49 EST
Description of problem:
If there are unformatted and LDL DASD disks on the system, anaconda running in graphical mode shows two same dialog windows asking to format unformatted and then LDL DASD disks using dasdfmt. Since the windows are same, it is not clear which dialog asks to format LDL /unformatted disks. Since text mode is going to ask just once (bug 1269955), we should do the same in GUI mode.

Version-Release number of selected component (if applicable):
RHEL-7.2 GA

How reproducible:
always

Steps to Reproduce:
1. have a system with unformatted and LDL DASD disks
2. run manual graphic installation
3. select all disks and go to the custom partitioning spoke

Actual results:
Two same dialog windows for unformatted and LDL DASD disks

Expected results:
One dialog for all unsupported/unusable DASD disks
Comment 2 Jan Stodola 2016-07-18 05:28:35 EDT
There is just one dialog window to dasdfmt all unformatted/LDL DASD disks, tested in both GUI and text mode.

There is an issue with no feedback while formatting DASD disks in GUI mode, which is reported as bug 1335465.

Tested with anaconda-21.48.22.79-1.el7

Moving to VERIFIED.
Comment 4 errata-xmlrpc 2016-11-03 19:23:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html

Note You need to log in before you can comment on or make changes to this bug.