Bug 131609 - xmms segfaults upon startup
xmms segfaults upon startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks: FC3Blocker 131589
  Show dependency treegraph
 
Reported: 2004-09-02 13:39 EDT by Matthias Clasen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-07 11:42:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2004-09-02 13:39:29 EDT
This is xmms-1.2.10-6

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -151067552 (LWP 21899)]
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x008cc79a in g_thread_self () from /usr/lib/libglib-2.0.so.0
#2  0x001cb951 in gsl_thread_self () from /usr/lib/libartsflow.so.1
#3  0x001cd954 in gsl_init () from /usr/lib/libartsflow.so.1
#4  0x00188ce8 in Arts::StdFlowSystem::StdFlowSystem ()
   from /usr/lib/libartsflow.so.1
#5  0x0018bd4b in Arts::SetFlowSystem::startup ()
   from /usr/lib/libartsflow.so.1
#6  0x00af4cc7 in Arts::StartupManager::startup () from
/usr/lib/libmcop.so.1
#7  0x00adae88 in Arts::Dispatcher::Dispatcher () from
/usr/lib/libmcop.so.1
#8  0x00e740a4 in arts_backend_init () from /usr/lib/libartscbackend.so.0
#9  0x002912b6 in arts_init () from /usr/lib/libartsc.so.0
#10 0x0808481a in main ()
(
Comment 1 Colin Walters 2004-09-03 15:39:34 EDT
I believe this crash is happening because xmms is using glib-1.2, and
the arts plugin is using glib-2.0.  Linking in different versions of
the threading system causes a crash.
Comment 2 Colin Walters 2004-09-07 11:42:11 EDT
This should be fixed by the latest arts upload.

Note You need to log in before you can comment on or make changes to this bug.