Bug 1316105 - /setup/agent/ points to "localhost" as the master in the minion config
Summary: /setup/agent/ points to "localhost" as the master in the minion config
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Alfredo Deza
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-09 12:30 UTC by Alfredo Deza
Modified: 2016-08-23 19:48 UTC (History)
11 users (show)

Fixed In Version: ceph-installer-1.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:48:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Alfredo Deza 2016-03-09 12:30:23 UTC
Description of problem: When trying to bootstrap the agent with the /setup/agent/ endpoint, it creates a /etc/salt/minion.d/ceph_agent.conf  file pointing to "localhost" as the master, which is wrong.


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. curl http://<ceph-installer-host>:8181/setup/agent/ | sudo bash
2. wait for the installation process to complete


Actual results:


Expected results: /etc/salt/minion.d/ceph_agent.conf  should have the address/hostname of the host for the ceph-installer, not "localhost"


Additional info:

Comment 2 Alfredo Deza 2016-03-09 20:07:25 UTC
Pull Request opened https://github.com/ceph/ceph-installer/pull/115

Comment 5 Mike McCune 2016-03-28 22:11:59 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 13 Martin Kudlej 2016-06-21 09:43:31 UTC
Checked with ceph-installer-1.0.11-1.el7scon.noarch and it works. -> Verified

Comment 15 errata-xmlrpc 2016-08-23 19:48:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.