Bug 1316124 - Error 'TypeError: redeclaration of const KEY_DELM' for scoped search of smart class parameter.
Error 'TypeError: redeclaration of const KEY_DELM' for scoped search of smart...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: orabin
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 08:23 EST by Jitendra Yejare
Modified: 2016-07-27 05:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:05:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot Attached (126.53 KB, image/png)
2016-03-09 08:23 EST, Jitendra Yejare
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14129 None None None 2016-04-22 11:36 EDT

  None (edit)
Description Jitendra Yejare 2016-03-09 08:23:35 EST
Created attachment 1134530 [details]
Screenshot Attached

Description of problem:
Firebug console shows Error 'TypeError: redeclaration of const KEY_DELM' for any search query in search box.

Version-Release number of selected component (if applicable):
Satellite 6.2 snap 2.1

How reproducible:
Always

Steps to Reproduce:
1. Create a repo with puppet module.
2. Create a CV with above puppet module and publish the CV.
3. Go to Configure -> Smart Class parameters, it will list parameters in a table.
4. Open a firebug Console-> errors.
5. Attempt to search a parameter with some query in search box.
e.g: 'override = True'

Actual results:
Firebug console shows an error 'TypeError: redeclaration of const KEY_DELM'.

Expected results:
No Error.

Additional info:
Comment 2 orabin 2016-03-10 00:49:50 EST
Created redmine issue http://projects.theforeman.org/issues/14129 from this bug
Comment 3 Bryan Kearney 2016-03-10 06:11:06 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/14129 has been closed
-------------
Ori Rabin
Applied in changeset commit:2e1dc83df509910f36753330b26fc74f7e59d2d5.
Comment 4 Jitendra Yejare 2016-03-23 03:35:14 EDT
The issue is no more reproducible in Sat 6.2 snap 4.

The reported error in not displayed in console.

So moving this to 'Verified'.
Comment 7 errata-xmlrpc 2016-07-27 05:05:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.