Bug 1316134 - Unable drag a widget to the bottom of the dashboard
Unable drag a widget to the bottom of the dashboard
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All All
medium Severity low
: GA
: cfme-future
Assigned To: Dávid Halász
Dmitry Misharov
ui:dashboard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 08:51 EST by Dmitry Misharov
Modified: 2017-08-21 09:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 09:06:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen recording of the bug (8.80 MB, application/octet-stream)
2016-03-10 03:21 EST, Dmitry Misharov
no flags Details

  None (edit)
Description Dmitry Misharov 2016-03-09 08:51:26 EST
Description of problem:
Widgets in the Dashboard can't be dragged to the bottom.

Version-Release number of selected component (if applicable):
5.5.2.4.20160127105142_395c086

How reproducible:
Alsways

Steps to Reproduce:
1. Go to Cloud Intelligence -> Dashboard.
2. Pick any not bottom widget.
3. Drag and drop it under any bottom widget.

Actual results:
Drag and drop action fails.

Expected results:
The widget should be placed under a bottom widget.
Comment 2 Harpreet Kataria 2016-03-09 15:40:05 EST
Dmitry,

Currently we only support 3 rows and columns for widgets on Dashboard screen, just wondering if you already have 3 rows and were trying to move dashboard into a 4th row, Can you please provide a screenshot of your Dashboard screen for clarity.

Thanks,
~Harpreet
Comment 3 Dmitry Misharov 2016-03-10 03:21 EST
Created attachment 1134758 [details]
Screen recording of the bug
Comment 4 Harpreet Kataria 2016-03-10 10:06:34 EST
David,

Can you look into this one, i tried to recreate and found that sometimes it doesn't let me drag/drop widgets from one column to another as a last item in the column, it works if i drag/drop widget in between 2 widgets.
Let me know if you need help recreating the issue.

Thanks,
~Harpreet
Comment 5 Dávid Halász 2016-03-15 10:48:36 EDT
Harpreet,

we're using jQuery UI sortable [1] which is not a full drag'n'drop implementation. You can move the items from column A to column B only if you change the order in the column B. But because of the external library we use, this is not a bug, but a feature.

[1] https://jqueryui.com/sortable/
Comment 9 Chris Pelland 2017-08-21 09:06:43 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.
Comment 10 Chris Pelland 2017-08-21 09:09:16 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.