Bug 1316147 - image-create does not respect the force_raw_images setting
image-create does not respect the force_raw_images setting
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Sahid Ferdjaoui
Prasanth Anbalagan
: ZStream
Depends On:
Blocks: 1194008 1335835
  Show dependency treegraph
 
Reported: 2016-03-09 09:20 EST by Chris St. Pierre
Modified: 2016-06-14 10:14 EDT (History)
13 users (show)

See Also:
Fixed In Version: openstack-nova-12.0.3-4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1335835 (view as bug list)
Environment:
Last Closed: 2016-06-14 10:14:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 226069 None None None 2016-03-10 09:12 EST

  None (edit)
Description Chris St. Pierre 2016-03-09 09:20:23 EST
Description of problem:

Upstream bug: https://bugs.launchpad.net/nova/+bug/1497484

We'd like the fix, currently under review at https://review.openstack.org/#/c/226069/, backported into OSP8.

Version-Release number of selected component (if applicable):

python-glance-11.0.1

How reproducible:

Always

Steps to Reproduce:

See upstream bug.

Actual results:

See upstream bug.

Expected results:

See upstream bug.

Additional info:
Comment 2 Charles Crouch 2016-04-15 18:22:49 EDT
Sahid, Nic has updated the upstream review, if that helps progress things.
Comment 3 Sahid Ferdjaoui 2016-04-19 09:17:23 EDT
(In reply to Charles Crouch from comment #2)
> Sahid, Nic has updated the upstream review, if that helps progress things.

Yes unfortunately we do not have a lot of reviews on this patch from upstream. I'll see what can we do to make things moving faster
Comment 4 Sahid Ferdjaoui 2016-04-26 11:04:00 EDT
The uptream patch is currently blocked because it could change the behavior of other virt drivers
Comment 6 Prasanth Anbalagan 2016-05-31 21:33:48 EDT
************
VERSION
************

[root@serverB ~(keystone_admin)]# yum list installed | grep openstack-nova
openstack-nova-api.noarch            1:12.0.3-1.el7ost       @rhelosp-8.0-puddle
openstack-nova-cert.noarch           1:12.0.3-1.el7ost       @rhelosp-8.0-puddle
openstack-nova-common.noarch         1:12.0.3-1.el7ost       @rhelosp-8.0-puddle
openstack-nova-conductor.noarch      1:12.0.3-1.el7ost       @rhelosp-8.0-puddle
openstack-nova-console.noarch        1:12.0.3-1.el7ost       @rhelosp-8.0-puddle
openstack-nova-novncproxy.noarch     1:12.0.3-1.el7ost       @rhelosp-8.0-puddle
openstack-nova-scheduler.noarch      1:12.0.3-1.el7ost       @rhelosp-8.0-puddle
[root@serverB ~(keystone_admin)]# 


************
LOGS
************

[root@serverB ~(keystone_admin)]# 
[root@serverB ~(keystone_admin)]# grep "use_cow_images" /etc/nova/nova.conf
use_cow_images=False
# VM Images format. If default is specified, then use_cow_images flag is used
[root@serverB ~(keystone_admin)]# grep "force_raw_images" /etc/nova/nova.conf
force_raw_images=true
[root@serverB ~(keystone_admin)]# grep "disk_format" /etc/glance/glance-api.conf 
# Supported values for the 'disk_format' image attribute (list value)
# Deprecated group/name - [DEFAULT]/disk_formats
#disk_formats=ami,ari,aki,vhd,vmdk,raw,qcow2,vdi,iso
disk_formats=ami,ari,aki,raw,iso
[root@serverB ~(keystone_admin)]# glance image-list
+--------------------------------------+--------+
| ID                                   | Name   |
+--------------------------------------+--------+
| 9a804bc4-9922-4bc2-9dd7-2fba7825142c | cirros |
+--------------------------------------+--------+
[root@serverB ~(keystone_admin)]# 
[root@serverB ~(keystone_admin)]# glance image-show 9a804bc4-9922-4bc2-9dd7-2fba7825142c
+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | 133eae9fb1c98f45894a4e60d8736619     |
| container_format | bare                                 |
| created_at       | 2016-05-27T15:57:57Z                 |
| disk_format      | qcow2                                |
| id               | 9a804bc4-9922-4bc2-9dd7-2fba7825142c |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | cirros                               |
| owner            | 8711cd26fa0f4cfe8f784842b5e2cf5a     |
| protected        | False                                |
| size             | 13200896                             |
| status           | active                               |
| tags             | []                                   |
| updated_at       | 2016-05-27T15:58:01Z                 |
| virtual_size     | None                                 |
| visibility       | public                               |
+------------------+--------------------------------------+
[root@serverB ~(keystone_admin)]# 

[root@serverB ~(keystone_admin)]# 
[root@serverB ~(keystone_admin)]# nova boot --flavor 1 --image cirros vm1
+--------------------------------------+-----------------------------------------------+
| Property                             | Value                                         |
+--------------------------------------+-----------------------------------------------+
| OS-DCF:diskConfig                    | MANUAL                                        |
| OS-EXT-AZ:availability_zone          |                                               |
| OS-EXT-SRV-ATTR:host                 | -                                             |
| OS-EXT-SRV-ATTR:hypervisor_hostname  | -                                             |
| OS-EXT-SRV-ATTR:instance_name        | instance-00000003                             |
| OS-EXT-STS:power_state               | 0                                             |
| OS-EXT-STS:task_state                | scheduling                                    |
| OS-EXT-STS:vm_state                  | building                                      |
| OS-SRV-USG:launched_at               | -                                             |
| OS-SRV-USG:terminated_at             | -                                             |
| accessIPv4                           |                                               |
| accessIPv6                           |                                               |
| adminPass                            | H55s9WXkYdhW                                  |
| config_drive                         |                                               |
| created                              | 2016-06-01T01:27:08Z                          |
| flavor                               | m1.tiny (1)                                   |
| hostId                               |                                               |
| id                                   | 6a191985-9c69-46de-85ed-4f2a08f268f2          |
| image                                | cirros (9a804bc4-9922-4bc2-9dd7-2fba7825142c) |
| key_name                             | -                                             |
| metadata                             | {}                                            |
| name                                 | vm1                                           |
| os-extended-volumes:volumes_attached | []                                            |
| progress                             | 0                                             |
| security_groups                      | default                                       |
| status                               | BUILD                                         |
| tenant_id                            | f2a35df709d2493e8f03af5c84632158              |
| updated                              | 2016-06-01T01:27:08Z                          |
| user_id                              | 345afd6e3df141ee855cd1f167a16a57              |
+--------------------------------------+-----------------------------------------------+
[root@serverB ~(keystone_admin)]# nov alist
-bash: nov: command not found
[root@serverB ~(keystone_admin)]# nova list
+--------------------------------------+------+--------+------------+-------------+---------------------+
| ID                                   | Name | Status | Task State | Power State | Networks            |
+--------------------------------------+------+--------+------------+-------------+---------------------+
| 6a191985-9c69-46de-85ed-4f2a08f268f2 | vm1  | ACTIVE | -          | Running     | public=172.24.4.229 |
+--------------------------------------+------+--------+------------+-------------+---------------------+
[root@serverB ~(keystone_admin)]# nova image-create --show --poll vm1 vm1_snap

Server snapshotting... 50% complete
Server snapshotting... 100% complete
Finished
+-------------------------+--------------------------------------+
| Property                | Value                                |
+-------------------------+--------------------------------------+
| OS-EXT-IMG-SIZE:size    | 1073741824                           |
| created                 | 2016-06-01T01:27:50Z                 |
| id                      | 6854b686-6372-4179-9863-e664f9e18c19 |
| metadata base_image_ref | 9a804bc4-9922-4bc2-9dd7-2fba7825142c |
| metadata image_location | snapshot                             |
| metadata image_state    | available                            |
| metadata image_type     | snapshot                             |
| metadata instance_uuid  | 6a191985-9c69-46de-85ed-4f2a08f268f2 |
| metadata owner_id       | f2a35df709d2493e8f03af5c84632158     |
| metadata user_id        | 345afd6e3df141ee855cd1f167a16a57     |
| minDisk                 | 1                                    |
| minRam                  | 0                                    |
| name                    | vm1_snap                             |
| progress                | 100                                  |
| server                  | 6a191985-9c69-46de-85ed-4f2a08f268f2 |
| status                  | ACTIVE                               |
| updated                 | 2016-06-01T01:30:00Z                 |
+-------------------------+--------------------------------------+
[root@serverB ~(keystone_admin)]# 
[root@serverB ~(keystone_admin)]# glance image-list
+--------------------------------------+----------+
| ID                                   | Name     |
+--------------------------------------+----------+
| 9a804bc4-9922-4bc2-9dd7-2fba7825142c | cirros   |
| 6854b686-6372-4179-9863-e664f9e18c19 | vm1_snap |
+--------------------------------------+----------+
Comment 7 Prasanth Anbalagan 2016-06-01 07:11:49 EDT
A copy paste mistake in the logs above. The verification was done on the following version,

[root@serverB ~(keystone_admin)]# yum list installed | grep openstack-nova
openstack-nova-api.noarch            1:12.0.3-6.el7ost       @rhelosp-8.0-puddle
openstack-nova-cert.noarch           1:12.0.3-6.el7ost       @rhelosp-8.0-puddle
openstack-nova-common.noarch         1:12.0.3-6.el7ost       @rhelosp-8.0-puddle
openstack-nova-conductor.noarch      1:12.0.3-6.el7ost       @rhelosp-8.0-puddle
openstack-nova-console.noarch        1:12.0.3-6.el7ost       @rhelosp-8.0-puddle
openstack-nova-novncproxy.noarch     1:12.0.3-6.el7ost       @rhelosp-8.0-puddle
openstack-nova-scheduler.noarch      1:12.0.3-6.el7ost       @rhelosp-8.0-puddle
Comment 9 errata-xmlrpc 2016-06-14 10:14:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1226

Note You need to log in before you can comment on or make changes to this bug.