Bug 1316173 - virsh cannot delete volume
virsh cannot delete volume
Status: CLOSED DUPLICATE of bug 1289327
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-03-09 10:04 EST by Vít Ondruch
Modified: 2016-03-09 10:33 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-03-09 10:33:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2016-03-09 10:04:44 EST
Description of problem:
I am trying to delete volume, but it is not possible for some reasons I really don§t understand why:

$ sudo virsh -d 4
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # vol-delete /var/lib/libvirt/images/projectatomic-VAGRANTSLASH-adb_vagrant_box_image_1.6.0.img
error: Failed to delete vol /var/lib/libvirt/images/projectatomic-VAGRANTSLASH-adb_vagrant_box_image_1.6.0.img
error: cannot unlink file '/var/lib/libvirt/images/projectatomic-VAGRANTSLASH-adb_vagrant_box_image_1.6.0.img': Operace zamítnuta

virsh # 

"Operace zamítnuta" could be translated as "Operation denied" not sure how to convince the origin of the message to speak different language :/

Also note that the same behavior exhibits virt-manager.

Version-Release number of selected component (if applicable):
$ rpm -qf `which virsh`

How reproducible:

Steps to Reproduce:
1. Use Vagrant together with Vagrant file with config.vm.box = "projectatomic/adb"
2. Try to get rid of the volume any way.

Actual results:
Cannot delete volume => operation denied

Expected results:
Can delete volume.

Additional info:
File system permissions if that might be of difference:

$ ls -laZ /var/lib/libvirt/images/projectatomic-VAGRANTSLASH-adb_vagrant_box_image_1.6.0.img
-rwxr--r--. 1 qemu qemu system_u:object_r:virt_content_t:s0 1752956928 Feb  4 13:07 /var/lib/libvirt/images/projectatomic-VAGRANTSLASH-adb_vagrant_box_image_1.6.0.img

And this is my LANG environment (I got the feeling that this might be relevant somehow, due to the "Operace zamítnuta" message):

$ env | grep LANG
Comment 1 Cole Robinson 2016-03-09 10:33:35 EST
I think this is the same issue as 1289327

*** This bug has been marked as a duplicate of bug 1289327 ***

Note You need to log in before you can comment on or make changes to this bug.