Bug 1316206 - erl_interface: regression in erl_decode for LLONG_MIN longlong value
erl_interface: regression in erl_decode for LLONG_MIN longlong value
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: erlang (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
  Show dependency treegraph
 
Reported: 2016-03-09 11:55 EST by Pino Toscano
Modified: 2016-06-23 13:54 EDT (History)
7 users (show)

See Also:
Fixed In Version: erlang-18.3.4-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 13:54:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simple reproducer (1.03 KB, text/plain)
2016-03-09 11:55 EST, Pino Toscano
no flags Details

  None (edit)
Description Pino Toscano 2016-03-09 11:55:36 EST
Created attachment 1134565 [details]
simple reproducer

Description of problem:
In libguestfs we have erlang bindings using OTP, and one of the tests involves passing limit values and checking that they are read as expected in the C API.

It seems erl_decode fails to decode -9223372036854775808 (which is LLONG_MIN) as ERL_LONGLONG value, giving a ERL_INTEGER with value -1.

The attached test case contains the dump of a message (the libguestfs add_drive_scratch call) whose second item in the tuple is a longlong.

Version-Release number of selected component (if applicable):
erlang-erl_interface-18.2.4-2.fc25.x86_64

How reproducible:
100% with the attached test case.

Steps to Reproduce:
1. build the testcase
2. run it

Actual results:
- f23:
TYPE is 137
TYPE is 17
- f24/rawhide:
TYPE is 137
TYPE is 1

17 = ERL_LONGLONG
1 = ERL_INTEGER

Expected results:
Same decoding result in f24/rawhide (i.e. as ERL_LONGLONG).
Comment 1 Fedora Update System 2016-06-13 11:30:52 EDT
erlang-18.3.3-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9ded469f1b
Comment 2 Peter Lemenkov 2016-06-13 11:32:41 EDT
Sorry for the delay. Could you please test the latest build and report if it works for you?
Comment 3 Richard W.M. Jones 2016-06-13 13:33:02 EDT
Yes it seems to be fixed.  I tested
erlang-18.3.3-2.fc25.x86_64
Comment 4 Fedora Update System 2016-06-13 23:58:11 EDT
erlang-18.3.3-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9ded469f1b
Comment 5 Pino Toscano 2016-06-15 04:50:28 EDT
(In reply to Peter Lemenkov from comment #2)
> Sorry for the delay. Could you please test the latest build and report if it
> works for you?

Tested the latest version, erlang-erl_interface-18.3.3-2.fc25.x86_64, from rawhide, and indeed it works now.

Thanks!
Comment 6 Fedora Update System 2016-06-15 05:44:10 EDT
erlang-18.3.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-70995ddd01
Comment 7 Fedora Update System 2016-06-15 12:56:04 EDT
erlang-18.3.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-70995ddd01
Comment 8 Fedora Update System 2016-06-23 13:54:46 EDT
erlang-18.3.4-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.