Bug 1316210 - Cannot set dm.basesize until docker has been started
Cannot set dm.basesize until docker has been started
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Stephen Chung
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 12:05 EST by Mason Jones
Modified: 2016-09-20 00:37 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-03 13:27:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mason Jones 2016-03-09 12:05:28 EST
Description of problem:

When using terraform to bring up a new EC2 instance with Docker, I wanted to modify the dm.basesize option before starting Docker. To do this, my script adds a line to the /etc/sysconfig/docker-storage file:

    DOCKER_STORAGE_OPTIONS= --storage-opt dm.basesize=50G

However, when it then tries to start Docker with systemctl start docker.service I was getting an error:

    Error starting daemon: error initializing graphdriver: Unknown option dm.basesize

I had used this same line before, but realized that it was after Docker had been started at least once on the server. So then I changed things to:

    systemctl start docker.service
    Add the line to /etc/sysconfigdocker-storage
    systemctl restart docker.service

This works fine. Maybe Docker needs to be started at least once on the server in order to initialize the storage subsystem somehow? Before that's done, it doesn't recognize the storage option. This is sort of crazy, so is there a proper fix/workaround?

Version-Release number of selected component (if applicable):

Output of "docker version": Docker version 1.7.1, build 446ad9b/1.7.1
This is on AWS EC2, running CentOS Linux release 7.1.1503 (Core).

I first asked this as an issue against Docker (https://github.com/docker/docker/issues/21037) but they said since it's a Red Hat-supported build of Docker it should be asked here.
Comment 1 Lokesh Mandvekar 2016-04-02 02:38:59 EDT
changing component to 'docker'. 'docker-io' isn't used anymore.
Comment 2 Daniel Walsh 2016-06-03 08:33:01 EDT
Stephen can you check if this is actually a bug.  I don't think it is.
Comment 3 Stephen Chung 2016-06-03 09:49:37 EDT
Right, I agree with Dan, I think it was a misunderstanding of the options available for the config file. The option in the config file should be EXTRA_DOCKER_STORAGE_OPTIONS. I think the user wanted to directly append the dm.basesize command to the DOCKER_STORAGE_OPTIONS seen in the default /usr/lib/docker-storage-setup/docker-storage-setup config file.

Note You need to log in before you can comment on or make changes to this bug.