Bug 1316213 - rhel-osp-director: Need to enhance the introspection completion message.
rhel-osp-director: Need to enhance the introspection completion message.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity unspecified
: rc
: 11.0 (Ocata)
Assigned To: Angus Thomas
Alexander Chuzhoy
: TestOnly, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 12:07 EST by Alexander Chuzhoy
Modified: 2017-05-17 15:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-17 15:27:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Chuzhoy 2016-03-09 12:07:21 EST
rhel-osp-director:  Need to enhance the introspection completion message.

Currently when the introspection completes, there's a message:
Discovery completed.

This should be changed to:

Introspection completed successfully for all nodes.
or
Introspection completed with errors on the following nodes: [list]


Otherwise the message is confusing for people new to openstack:
1. They start introspection, but the message is "discovery completed".
2. When there's a large number of nodes being discovered, lines with "Node <id> has been set to available." make the error less visibly and one might assume that the discovery went well.
Comment 2 Mike Burns 2016-04-07 17:14:44 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 3 James Slagle 2016-10-14 11:25:15 EDT
Removing from OSP10, not a blocker/regression
Comment 4 Bob Fournier 2017-04-11 11:46:08 EDT
I believe this is resolved, in python-tripleoclient/tripleoclient/workflows/baremetal.py errors are now being logged

    if errors:
        raise exceptions.IntrospectionError(
            "Introspection completed with errors:\n%s" % '\n'
            .join(errors))

    print("Introspection completed.")

Will need to simulate introspection error to confirm.
Comment 5 Bob Fournier 2017-04-12 10:53:49 EDT
I believe this is fixed.  If there is an introspection error the "Introspection completed" shows it, along with the node ID.

Introspection for UUID e25c4464-3c7e-44fc-acf1-06e5ba7551fb finished with error: Introspection timeout
Introspection for UUID 1c313b56-8700-4bd2-a9d8-932d177ac5e0 finished with error: Introspection timeout
Introspection completed with errors:
e25c4464-3c7e-44fc-acf1-06e5ba7551fb: Introspection timeout
1c313b56-8700-4bd2-a9d8-932d177ac5e0: Introspection timeout

undercloud) [stack@host01 ~]$ ironic node-list
+--------------------------------------+-------+---------------+-------------+--------------------+-------------+
| UUID                                 | Name  | Instance UUID | Power State | Provisioning State | Maintenance |
+--------------------------------------+-------+---------------+-------------+--------------------+-------------+
| 1c313b56-8700-4bd2-a9d8-932d177ac5e0 | host2 | None          | power on    | manageable         | False       |
| e25c4464-3c7e-44fc-acf1-06e5ba7551fb | host3 | None          | power on    | manageable         | False       |
+--------------------------------------+-------+---------------+-------------+--------------------+-------------+
Comment 6 Alexander Chuzhoy 2017-04-12 12:36:15 EDT
Verified:

Environment:
openstack-ironic-api-7.0.0-3.el7ost.noarch
python-ironic-lib-2.5.2-1.el7ost.noarch
python-ironicclient-1.11.1-1.el7ost.noarch
openstack-ironic-inspector-5.0.0-3.el7ost.noarch
instack-undercloud-6.0.0-5.el7ost.noarch
openstack-ironic-common-7.0.0-3.el7ost.noarch
puppet-ironic-10.4.0-3.el7ost.noarch
python-ironic-inspector-client-1.11.0-1.el7ost.noarch
openstack-ironic-conductor-7.0.0-3.el7ost.noarch

############################   GOOD result #################################

[stack@undercloud ~]$ openstack baremetal introspection bulk start
This command is deprecated. Please use "openstack overcloud node introspect" to introspect manageable nodes instead.
Setting nodes for introspection to manageable...                                                                                                                                              
Starting introspection of manageable nodes                                                                                                                                                    
Started Mistral Workflow tripleo.baremetal.v1.introspect_manageable_nodes. Execution ID: f8ceec85-0a54-44a7-b2b1-6c3d57dc0cb0
Waiting for introspection to finish...
Waiting for messages on queue '8cce3b91-7687-4449-a1ed-e3f6dcc1c73f' with no timeout.



Introspection for UUID 9443dd68-c0df-4604-856a-f35fc9cd46b6 finished successfully.
Introspection for UUID 637ee673-c727-47a7-9429-2bed9bf01e0b finished successfully.
Introspection for UUID 1a835055-7016-4dd0-92c5-63b653bd63a3 finished successfully.
Introspection for UUID da7410ce-fb29-4bf0-9644-d481d9bbe519 finished successfully.
Introspection for UUID 5fbb905a-449f-4dd3-816c-1c49587cd9a4 finished successfully.
Introspection for UUID f37625ee-e5c5-4834-a34f-22effb37fbc4 finished successfully.
Introspection for UUID 86fb95e3-10fc-493d-9c33-690971f74e24 finished successfully.
Introspection for UUID 9771379e-f6d4-4121-8e84-c0f9474095f6 finished successfully.
Introspection completed.
Setting manageable nodes to available...
Started Mistral Workflow tripleo.baremetal.v1.provide_manageable_nodes. Execution ID: f9119dfd-2502-4966-96f0-91c24a8d8703
Waiting for messages on queue '8cce3b91-7687-4449-a1ed-e3f6dcc1c73f' with no timeout.


############################   BAD result #################################

[stack@undercloud ~]$ openstack baremetal introspection bulk start
This command is deprecated. Please use "openstack overcloud node introspect" to introspect manageable nodes instead.
Setting nodes for introspection to manageable...
Starting introspection of manageable nodes
Started Mistral Workflow tripleo.baremetal.v1.introspect_manageable_nodes. Execution ID: 853b5f28-e84f-4fd9-b9ed-0281d7c3eedf
Waiting for introspection to finish...
Waiting for messages on queue 'cbf25bba-093d-414d-b14a-7c20eb7b7229' with no timeout.





Introspection for UUID 9443dd68-c0df-4604-856a-f35fc9cd46b6 finished successfully.
Introspection for UUID 637ee673-c727-47a7-9429-2bed9bf01e0b finished with error: Introspection timeout
Introspection for UUID 1a835055-7016-4dd0-92c5-63b653bd63a3 finished successfully.
Introspection for UUID 5fbb905a-449f-4dd3-816c-1c49587cd9a4 finished successfully.
Introspection for UUID f37625ee-e5c5-4834-a34f-22effb37fbc4 finished successfully.
Introspection for UUID 86fb95e3-10fc-493d-9c33-690971f74e24 finished successfully.
Introspection for UUID 9771379e-f6d4-4121-8e84-c0f9474095f6 finished successfully.
Introspection completed with errors:
637ee673-c727-47a7-9429-2bed9bf01e0b: Introspection timeout
Comment 8 errata-xmlrpc 2017-05-17 15:27:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245

Note You need to log in before you can comment on or make changes to this bug.