Bug 1316246 - [RFE] find out if foreman-installer --upgrade was run after yum update
Summary: [RFE] find out if foreman-installer --upgrade was run after yum update
Status: CLOSED DUPLICATE of bug 1459358
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades
Version: 6.1.8
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Keywords: FutureFeature, Triaged, UserExperience
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker 260381
TreeView+ depends on / blocked
 
Reported: 2016-03-09 18:53 UTC by Chris Roberts
Modified: 2018-06-22 13:24 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-06-22 13:24:45 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 16940 None None None 2016-10-14 13:50 UTC
Red Hat Bugzilla 1512600 None ASSIGNED [RFE] Implement a yum version lock type of protections against upgrades 2019-04-17 11:59 UTC

Internal Trackers: 1512600

Description Chris Roberts 2016-03-09 18:53:46 UTC
Description of problem:
When running a yum update with a minor release, alot of times the --upgrade flag is not run with katello-installer which can result in multiple issues.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install 6.1 latest then when next minor release comes out just do a yum update 

Actual results:
Satellite will experience issues at some point in the future.

Expected results:
have a way to verify if ## katello-installer --upgrade" was run after a yum update.

Additional info:

Comment 3 Daniel Lobato Garcia 2016-04-14 10:30:30 UTC
Not sure this is 'the fix' for this, but this might catch some errors on upgrade: https://github.com/theforeman/foreman/pull/3426

Comment 4 Stephen Benjamin 2016-10-14 13:50:48 UTC
Created redmine issue http://projects.theforeman.org/issues/16940 from this bug

Comment 5 Bryan Kearney 2018-06-22 13:24:45 UTC

*** This bug has been marked as a duplicate of bug 1459358 ***


Note You need to log in before you can comment on or make changes to this bug.