Bug 1316265 - Dependencies need updating
Dependencies need updating
Status: CLOSED DUPLICATE of bug 1152063
Product: Fedora
Classification: Fedora
Component: leksah-server (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 14:48 EST by Peter Trenholme
Modified: 2016-05-09 06:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-09 06:38:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2016-03-09 14:48:15 EST
Description of problem: Update of gtk, gio, etc. is blocked because the (installed) leksah-server requires (ex[licitly?) the older versions.

Version-Release number of selected component (if applicable): 0.14.3.1-4

How reproducible: Every time

Steps to Reproduce: Run "dnf upgrade"

Actual results: List of skipped ghc updates

Expected results: Updates to newer versions

Additional info: Output from "dnf --best upgrade":

Error: package ghc-leksah-server-0.14.3.1-4.fc24.x86_64 requires ghc(ltk-0.14.3.0-ab0eb58cdab3264993760458a60f091e), but none of the providers can be installed.
package leksah-server-0.14.3.1-4.fc24.x86_64 requires ghc(gio-0.13.1.0-ac32efefa85d87eec2d88a0b67be900c), but none of the providers can be installed.
package leksah-server-0.14.3.1-4.fc24.x86_64 requires ghc(gtk-0.13.9-ee187763d36f17a02bbe07a69d1e5455), but none of the providers can be installed.
package ghc-ltk-0.14.3.0-4.fc24.x86_64 requires ghc(gtk-0.13.9-ee187763d36f17a02bbe07a69d1e5455), but none of the providers can be installed
Comment 1 Peter Robinson 2016-05-09 06:37:45 EDT
(In reply to Peter Trenholme from comment #0)
> Description of problem: Update of gtk, gio, etc. is blocked because the
> (installed) leksah-server requires (ex[licitly?) the older versions.

You analysis here is wrong, it's because the package is FTBFS.
Comment 2 Peter Robinson 2016-05-09 06:38:49 EDT

*** This bug has been marked as a duplicate of bug 1152063 ***

Note You need to log in before you can comment on or make changes to this bug.