This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1316280 - The Power-Stop used for Azure is not the same as the Azure Portal Stop
The Power-Stop used for Azure is not the same as the Azure Portal Stop
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.6.0
Unspecified Unspecified
high Severity medium
: GA
: 5.6.0
Assigned To: Daniel Berger
Jeff Teehan
provision:ui:azure:power
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 16:24 EST by Jeff Teehan
Modified: 2016-06-29 11:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:41:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Teehan 2016-03-09 16:24:29 EST
Description of problem:

Azure supports two automation modes for Stopping a VM.  Stopped is effectively Paused.  The machine resources are still available and it is still incurring charges as if it were running.  However, in the Azure Portal, when you select a VM and click Stop, it performs the Stopped(Deallocated) command which is the same thing as going into the VM and choosing Shutdown.

When I select CloudForms Power:Stop on a running Azure VM, is sends the first stopped.  But if I go to that VM in the Portal, the Stop option is still available, and the VM is still costing me money.  There is a better description of the differences here:

https://blogs.technet.microsoft.com/uspartner_ts2team/2014/10/10/azure-virtual-machines-stopping-versus-stopping-deallocating/

I can't say it's busted, but unless we provide both options in the Power menu, I would suggest we use the same behavior as the Azure portal.

As always, I'm open to further discussions.

Version-Release number of selected component (if applicable):
5.6

How reproducible:
Always

Steps to Reproduce:
1. In CF, select an Azure VM and choose Stop from the Power Dropdown
2. Go to Azure Portal, select VM and choose Stop.
3.

Actual results:

I would think we should copy the same behavior as if the user were in Azure.

Expected results:


Additional info:
Comment 2 Jeff Teehan 2016-03-09 16:26:25 EST
This is not a 5.6 regression.  5.5 worked the same way although I didn't notice until my account got locked out for exceeding charges limit.
Comment 3 Daniel Berger 2016-04-20 15:48:16 EDT
Ok, how about "stop" for deallocation and "suspend" (or "pause") for just a power off?
Comment 4 Jeff Teehan 2016-04-20 15:56:31 EDT
Do it.
Comment 5 Daniel Berger 2016-04-21 10:46:29 EDT
PR submitted: https://github.com/ManageIQ/manageiq/pull/8152
Comment 6 Jeff Teehan 2016-05-04 13:30:57 EDT
This works.  Tested 5605 using https://10.16.6.211/vm_cloud/explorer#

Moving to Verified.
Comment 8 errata-xmlrpc 2016-06-29 11:41:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.