Bug 1316282 - Events from vSphere stop working shortly after an appliance reboot (20-30 minute)
Events from vSphere stop working shortly after an appliance reboot (20-30 min...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Adam Grare
Nandini Chandra
event
: ZStream
Depends On:
Blocks: 1322002 1322004
  Show dependency treegraph
 
Reported: 2016-03-09 16:29 EST by Jared Deubel
Modified: 2016-09-13 14:47 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.1
Doc Type: Bug Fix
Doc Text:
Previously, using HTTP timeout with the WaitForUpdates method caused calls to VMware vSphere to hang. Consequently, vSphere events stopped working 20-30 minutes after an appliance reboot. VMware vSphere 4.1 added the WaitForUpdatesEx method to address the issue of WaitForUpdates blocking processes for a long time. This CloudForms release contains WaitForUpdatesEx, which can be used with the maxWait property to configure blocking limits for WaitForUpdatesEx without needing to time out the connection.
Story Points: ---
Clone Of:
: 1322002 1322004 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:41:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 14:50:04 EDT

  None (edit)
Description Jared Deubel 2016-03-09 16:29:52 EST
Description of problem:

We are encountering an issue on CF 3.2 with catching events from VMware for provisioning performed outside CF directly in vCenter, and for power events.  

* vCenter 5.5 appliance on laptop.  Initially VmDeploy events are received for start and finish:

After the events stop we are still seeing property changes come in and the worker still running. 

Ongoing issue that is causing provisioning failures and Administration issues.

Version-Release number of selected component (if applicable):
5.4

How reproducible:
100%
Comment 12 Nandini Chandra 2016-04-28 23:58:14 EDT
I haven't been able to reproduce this issue.

Marking this as VERIFIED since GSS has confirmed that the fix resolved the issue.
Comment 15 errata-xmlrpc 2016-06-29 11:41:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.