Bug 1316307 - Systemd Presets policy do not match preset for lvm2 in RHEL
Systemd Presets policy do not match preset for lvm2 in RHEL
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: redhat-release (Show other bugs)
7.2
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Lubos Kocman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 18:03 EST by Aaron Howell
Modified: 2017-08-01 13:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 13:29:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Howell 2016-03-09 18:03:00 EST
Description of problem:
lvm2-lvmpolld.socket is set to forcibly enable in the RPM --scripts for lvm2. However the Red Hat provided systemd preset policy (redhat-release-server) does not match this enforced state (/usr/lib/systemd/system-preset/90-default.preset)

Version-Release number of selected component (if applicable):
redhat-release-server-7.2-9.el7.x86_64
lvm2-2.02.130-5.el7_2.1.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. sudo systemctl status lvm2-lvmpolld.socket

Actual results:
● lvm2-lvmpolld.socket - LVM2 poll daemon socket
   Loaded: loaded (/usr/lib/systemd/system/lvm2-lvmpolld.socket; enabled; vendor preset: disabled)
   Active: active (listening) since Wed 2016-03-09 15:56:51 AEDT; 17h ago
     Docs: man:lvmpolld(8)
   Listen: /run/lvm/lvmpolld.socket (Stream)


Expected results:
● lvm2-lvmpolld.socket - LVM2 poll daemon socket
   Loaded: loaded (/usr/lib/systemd/system/lvm2-lvmpolld.socket; enabled; vendor preset: enabled)
   Active: active (listening) since Wed 2016-03-09 15:56:51 AEDT; 17h ago
     Docs: man:lvmpolld(8)
   Listen: /run/lvm/lvmpolld.socket (Stream)


Additional info:
rpm -q --scripts lvm2
....
if [ $1 -eq 1 ] ; then 
        # Initial installation 
        systemctl preset lvm2-lvmpolld.socket >/dev/null 2>&1 || : 
fi 

# lvm2-lvmpolld socket is always enabled and started and ready to serve if lvmpolld is used
# replace direct systemctl calls with systemd rpm macro once this is provided in the macro:
# http://cgit.freedesktop.org/systemd/systemd/commit/?id=57ab2eabb8f92fad5239c7d4492e9c6e23ee0678
systemctl enable lvm2-lvmpolld.socket
systemctl start lvm2-lvmpolld.socket
....

We can work around this by placing in our own preset policy to enable it in /etc/systemd/system-preset/, but Redhat should already provide this policy if it is the default or only use systemctl preset in the RPM.
Comment 3 Lubos Kocman 2017-02-02 08:48:15 EST
I agree that we should fix this, adding devel_ack+

Lubos
Comment 4 Lubos Kocman 2017-03-06 11:08:51 EST
Updated in redhat-release-{server,client,workstation,computenode}
Comment 6 errata-xmlrpc 2017-08-01 13:29:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1850

Note You need to log in before you can comment on or make changes to this bug.