Bug 1316309 - Satellite 6.2 upgrade: check current Sat 6 version and fail/exit if below 6.1.9 with instructions to update first
Satellite 6.2 upgrade: check current Sat 6 version and fail/exit if below 6.1...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades (Show other bugs)
6.2.0
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: David Davis
Katello QA List
http://projects.theforeman.org/issues...
: PrioBumpGSS, Triaged, UserExperience
Depends On: 1315269
Blocks: GSS_Sat6Beta_Tracker/GSS_Sat6_Tracker
  Show dependency treegraph
 
Reported: 2016-03-09 18:13 EST by Xixi
Modified: 2017-02-23 14:38 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-16 18:06:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14306 None None None 2016-04-22 11:38 EDT

  None (edit)
Description Xixi 2016-03-09 18:13:25 EST
Description of problem:
Satellite 6.2 upgrade requires existing Sat 6 installation to be at least 6.1.9 update level, otherwise it may fail, or end up removing content nodes which would prevent updates post-upgrade.  Satellite 6.2 upgrade tooling needs to first check if underlying Satellite is at 6.1.9 or newer.  If not, exit and explain to user how to update to 6.1.9 first before re-attempting upgrade to 6.2.0.

Version-Release number of selected component (if applicable):
Satellite 6.2

How reproducible:
always

Steps to Reproduce:
1. upgrade to Satellite 6.2 from unsupported version
2.
3.

Actual results:
upgrade fails, or succeed but with severe support or functionality ramifications

Expected results:
Check current Satellite version first to make sure customer is upgrading from 6.1.9 or newer Sat 6.1 GA version to 6.2.0 GA version.  If older than 6.1.9, message user to update to 6.1.9 first (and how).

Additional info:
Comment 5 Stephen Benjamin 2016-03-21 15:29:24 EDT
Created redmine issue http://projects.theforeman.org/issues/14306 from this bug
Comment 6 Stephen Benjamin 2016-05-17 11:28:05 EDT
Can't find a particularly good way to do this - what's the reason we need to do it?

There's no RPM facility to prevent this that I can think of, and tried a few ways and none of them really work.  I thought about failing in %pre but that only affects 1 rpm, not the entire transaction (PR discussion here: https://github.com/Katello/katello-packaging/pull/224).
Comment 7 David Davis 2016-06-02 14:09:37 EDT
Handling this as part of https://bugzilla.redhat.com/show_bug.cgi?id=1315269
Comment 8 Bryan Kearney 2016-06-02 14:13:11 EDT
Upstream bug assigned to stbenjam@redhat.com
Comment 9 Bryan Kearney 2016-06-02 14:13:15 EDT
Upstream bug assigned to stbenjam@redhat.com
Comment 10 Bryan Kearney 2016-06-07 10:13:50 EDT
Upstream bug assigned to daviddavis@redhat.com
Comment 11 Bryan Kearney 2016-06-07 10:13:53 EDT
Upstream bug assigned to daviddavis@redhat.com
Comment 14 Mike McCune 2016-09-16 18:06:52 EDT
we shipped this in RHBA-2016:1499-03

Note You need to log in before you can comment on or make changes to this bug.