Bug 131635 - gnome-windows-properties slightly confusing
Summary: gnome-windows-properties slightly confusing
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 131589
TreeView+ depends on / blocked
 
Reported: 2004-09-02 19:21 UTC by Matthias Clasen
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-07 19:38:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Clasen 2004-09-02 19:21:20 UTC
The dialog lists Alt, Ctrl, Hyper, Super as modifiers, which is
slightly confusing, since both Hyper and Super are mapped to mod4 in
our default modifier mapping, so selecting either has the same effect.

It would be better to either

*) Remove the Hyper choice from the dialog

or

*) Map Hyper to a different modifier (mod3 is currently free)

Comment 1 Jonathan Blandford 2004-09-02 21:44:01 UTC
A good fix would be to only show those in the dialog if they're bound:

We can call gdk_keymap_get_entries_for_keycode() to check if either
are there, and show them in those instances.


Note You need to log in before you can comment on or make changes to this bug.