Bug 1316354 - "Guest Details" under "Help" menu of virt-viewer GUI for ko-kr is not translated
"Guest Details" under "Help" menu of virt-viewer GUI for ko-kr is not translated
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.8
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
: Translation
Depends On:
Blocks: 1395655
  Show dependency treegraph
 
Reported: 2016-03-09 21:54 EST by xiaodwan
Modified: 2017-03-21 05:17 EDT (History)
12 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-17.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 05:17:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing ko translation "게스트 정보 (_G)" for the source string "_Guest Details" with virt-viewer-2.0-17.el6.x86_64 (193.70 KB, image/png)
2016-10-24 06:36 EDT, sandeep shedmake
no flags Details

  None (edit)
Description xiaodwan 2016-03-09 21:54:52 EST
Description of problem:
"Guest Details" under "Help" menu of virt-viewer GUI for ko-kr is not translated

Version-Release number of selected component (if applicable):
virt-viewer-2.0-14.el6.x86_64.

How reproducible:
100%

Steps to Reproduce:
1.Preapre a running guest.
2.Use virt-viewer to test launch virt-viewer GUI,ues the below script to test different locales.
# export LANG=ko_KR.UTF-8; virt-viewer $dom
3.Click "Help" menu from virt-viewer GUI,there is option "Guest Details",which is always showed as English.

Actual results:
Step 3,"Guest Details" under "Help" menu of virt-viewer GUI is always showed as English.

Expected results:
Step 3,"Guest Details" under "Help" menu of virt-viewer GUI is translated in ko_KR locales.

Additional info:
This bug is used to track ko_KR problem in bug 1194474.
Comment 7 Noriko Mizumoto 2016-09-20 01:30:49 EDT
Hi Pavel

Thank you so much.
It seems that other languages also receive some update, so I will organize all languages update instead just ko-KR. I am looking at to schedule rhel-6.9 translation update in mid October.
Comment 8 Noriko Mizumoto 2016-10-20 01:44:46 EDT
Hi Pavel, 
We have completed RHEL6 branch translation 100% for 10 supported languages.
Please include them in your package. Thanks!
https://translate.engineering.redhat.com/iteration/view/virt-viewer/RHEL6/
Comment 9 Pavel Grunt 2016-10-20 03:21:43 EDT
(In reply to Noriko Mizumoto from comment #8)
> Hi Pavel, 
> We have completed RHEL6 branch translation 100% for 10 supported languages.
> Please include them in your package. Thanks!
> https://translate.engineering.redhat.com/iteration/view/virt-viewer/RHEL6/

Thank you, included
Comment 11 sandeep shedmake 2016-10-24 06:36 EDT
Created attachment 1213446 [details]
Screenshot showing ko translation "게스트 정보 (_G)" for the source string "_Guest Details" with virt-viewer-2.0-17.el6.x86_64

[root@client1 test]# cat /etc/redhat-release 
Red Hat Enterprise Linux Client release 6.8 (Santiago)
[root@client1 test]# rpm -q virt-viewer
virt-viewer-2.0-17.el6.x86_64
[root@client1 po]$  pwd
/home/sshedmak/rpmbuild/BUILD/virt-viewer-2.0/po
[sshedmak@client1 po]$ grep -n -A1 "_Guest Details" ko.po 
767:msgid "_Guest Details"
768-msgstr "게스트 정보 (_G)"
[sshedmak@client1 po]$ echo $?
0
Comment 14 errata-xmlrpc 2017-03-21 05:17:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0587.html

Note You need to log in before you can comment on or make changes to this bug.