Bug 1316378 - atomic-openshift-installer detect installed environment incorrectly
atomic-openshift-installer detect installed environment incorrectly
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Munilla
Anping Li
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 01:33 EST by Gaoyun Pei
Modified: 2016-08-18 15:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously when attempting to perform an initial installation on all new hosts, the quick installer incorrectly detected an "Installed environment" if a stand-alone load balancer host was included. This bug fix updates the installer to properly identify these configurations and allow the installation to continue as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-18 15:28:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2016-03-10 01:33:31 EST
Description of problem:
Install an HA master env using atomic-openshift-installer, after input 3 masters and one lb hosts, the installer said "Installed environment detected" when doing "Gathering information from hosts...", actually all the hosts are clean RHEL hosts.  

Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.0.55-1.git.0.b1d3c6d.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1.[root@host-192-168-1-57 ~]# atomic-openshift-installer install
...

*** Installation Summary ***

Hosts:
- 10.1.1.101
  - OpenShift Master
  - OpenShift Node
  - Etcd Member
  - Storage
- 10.1.1.102
  - OpenShift Master
  - OpenShift Node
  - Etcd Member
- 10.1.1.103
  - OpenShift Master
  - OpenShift Node
  - Etcd Member
- 10.1.1.104
  - Load Balancer (HAProxy)

Total OpenShift Masters: 3
Total OpenShift Nodes: 3

NOTE: Multiple Masters specified, this will be an HA deployment with a separate
etcd cluster. You will be prompted to provide the FQDN of a load balancer and
a host for storage once finished entering hosts.


WARNING: Dedicated Nodes are recommended for an HA deployment. If no dedicated
Nodes are specified, each configured Master will be marked as a schedulable
Node.

Gathering information from hosts...
Installed environment detected.
By default the installer only adds new nodes to an installed environment.
Do you want to (1) only add additional nodes or (2) reinstall the existing hosts potentially erasing any custom changes?: 2
10.1.1.101 is currently uninstalled
10.1.1.102 is currently uninstalled
10.1.1.103 is currently uninstalled
Adding additional nodes...
Writing config to: /root/.config/openshift/installer.cfg.yml


Actual results:
"Installed environment detected."
The Load Balancer host to be installed on was considered as installed.


Expected results:
Should start installation directly since it's a fresh install.

Additional info:
Comment 1 Samuel Munilla 2016-06-29 13:44:19 EDT
https://github.com/openshift/openshift-ansible/pull/2062 should handle this case as well.
Comment 4 Gan Huang 2016-08-15 05:11:44 EDT
Verified with atomic-openshift-utils-3.2.22-1.git.0.7961a61.el7.noarch
Comment 6 errata-xmlrpc 2016-08-18 15:28:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1639

Note You need to log in before you can comment on or make changes to this bug.