Bug 1316379 - Net::SSLeay does not support setting elliptic curve parameters
Net::SSLeay does not support setting elliptic curve parameters
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: perl-Net-SSLeay (Show other bugs)
7.2
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: perl-maint-list
Karel Srot
Lenka Špačková
http://cpansearch.perl.org/src/MIKEM/...
: FutureFeature, Patch
Depends On:
Blocks: 1316377
  Show dependency treegraph
 
Reported: 2016-03-10 01:35 EST by Karel Srot
Modified: 2016-11-03 21:02 EDT (History)
8 users (show)

See Also:
Fixed In Version: perl-Net-SSLeay-1.55-4.el7
Doc Type: Enhancement
Doc Text:
Perl *Net:SSLeay* now supports elliptic curve parameters Support for elliptic-curve parameters has been added to the Perl *Net:SSLeay* module, which contains bindings to the OpenSSL library. Namely, the `EC_KEY_new_by_curve_name()`, `EC_KEY_free*()`, `SSL_CTX_set_tmp_ecdh()`, and `OBJ_txt2nid()` subroutines have been ported from upstream. This is required for the support of the Elliptic Curve Diffie–Hellman Exchange (ECDHE) key exchange in the *IO::Socket::SSL* Perl module.
Story Points: ---
Clone Of: 1044401
Environment:
Last Closed: 2016-11-03 21:02:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upstream ECDHE support ported to 1.55 (1.65 KB, patch)
2016-03-10 08:04 EST, Jitka Plesnikova
no flags Details | Diff

  None (edit)
Description Karel Srot 2016-03-10 01:35:15 EST
RHEL-7 version doesn't support ECDHE while it is being added to RHEL-6.8

+++ This bug was initially created as a clone of Bug #1044401 +++

This bug report will be used for enabling perl server to set elliptic curve parameters.

The wrong setting cipher list in perl-LDAP what is the root cause if the initial comment will be solved in bug report #1090966.

--- Additional comment from Petr Pisar on 2015-11-13 06:11:03 EST ---

Fixed with commit 22c79946c1d8c09979140c088dedbce00599529b.

--- Additional comment from Petr Pisar on 2015-11-13 06:50:21 EST ---

How to test:

Use perl-IO-Socket-SSL test described in bug #1078084.

Or just verify following 4 subroutines are defined in Net::SSLeay name space:

  EC_KEY_free()
  EC_KEY_new_by_curve_name()
  OBJ_txt2nid()
  SSL_CTX_set_tmp_ecdh()
Comment 1 Jitka Plesnikova 2016-03-10 08:04 EST
Created attachment 1134888 [details]
Upstream ECDHE support ported to 1.55
Comment 6 errata-xmlrpc 2016-11-03 21:02:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2221.html

Note You need to log in before you can comment on or make changes to this bug.