This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1316383 - [abrt] hamster-time-tracker: facttree.py:260:on_mouse_down:ValueError: <hamster.lib.Fact object at 0x7f4d9806f510> is not in list
[abrt] hamster-time-tracker: facttree.py:260:on_mouse_down:ValueError: <hamst...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hamster-time-tracker (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:dd1bf281f0cda9497d1d1b918dc...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 01:52 EST by Dan Callaghan
Modified: 2016-04-02 16:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: hamster-time-tracker-2.0-0.7.rc1.fc23 hamster-time-tracker-2.0-0.7.rc1.fc24 hamster-time-tracker-2.0-0.8.rc1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 14:10:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (498 bytes, text/plain)
2016-03-10 01:52 EST, Dan Callaghan
no flags Details
File: environ (970 bytes, text/plain)
2016-03-10 01:52 EST, Dan Callaghan
no flags Details

  None (edit)
Description Dan Callaghan 2016-03-10 01:52:23 EST
Version-Release number of selected component:
hamster-time-tracker-2.0-0.2.rc1.fc22

Additional info:
reporter:       libreport-2.6.4
cmdline:        python2 /usr/bin/hamster-windows-service
executable:     /usr/bin/hamster-windows-service
kernel:         4.3.4-200.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            15550

Truncated backtrace:
facttree.py:260:on_mouse_down:ValueError: <hamster.lib.Fact object at 0x7f4d9806f510> is not in list

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/hamster/widgets/facttree.py", line 260, in on_mouse_down
    self.set_current_fact(self.facts.index(self.hover_fact))
ValueError: <hamster.lib.Fact object at 0x7f4d9806f510> is not in list

Local variables in innermost frame:
self: <FactTree 139971242506192>
event: <void at 0x28ea6f0>
scene: <FactTree 139971242506192>
Comment 1 Dan Callaghan 2016-03-10 01:52:29 EST
Created attachment 1134701 [details]
File: backtrace
Comment 2 Dan Callaghan 2016-03-10 01:52:30 EST
Created attachment 1134702 [details]
File: environ
Comment 3 Raphael Groner 2016-03-10 07:02:16 EST
Thanks for your report. Can you reproduce this crash? Please describe in more detail what you did. Maybe it's related specifically to your database entries, we saw another case with bogus entries in past.

The source file where it crashed:
https://github.com/projecthamster/hamster/blob/master/src/hamster/widgets/facttree.py#L260
Comment 4 Dan Callaghan 2016-03-10 18:00:35 EST
Sorry I should have filled in more detail in the abrt report. Unfortunately I have no idea what I did to trigger this. I know it was a mouse click, while I was in the middle of entering a backdated activity, but I don't know what I clicked on or what state anything was in because I was rushing and kind of fat-fingered it.

I don't *think* my database is corrupted, because everything is still working fine and I haven't noticed any data loss. It *is* a very old database though, dating back to probably 2011 and has been written to by all the various hamster versions over the years (back then it was still the original GNOME panel applet) so that might make some difference.

The other thing that might be unusual about my setup is that I use the xmonad window manager and XFCE, not GNOME. So I'm not sure if there is some assumptions that the activity entry makes (for example, maybe the activity entry window is a modal dialog in GNOME?) which aren't true in my environment.

Anyway, since I have no idea how to reproduce this, feel free to close the bug. I just thought I should let abrt report is so that there is a record of the crash.
Comment 5 Fedora Update System 2016-03-12 13:48:33 EST
hamster-time-tracker-2.0-0.7.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c8d09c09ea
Comment 6 Fedora Update System 2016-03-12 13:48:51 EST
hamster-time-tracker-2.0-0.7.rc1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-211cb25c0d
Comment 7 Fedora Update System 2016-03-12 13:50:12 EST
hamster-time-tracker-2.0-0.7.rc1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1b469d9a2d
Comment 8 Fedora Update System 2016-03-13 21:20:16 EDT
hamster-time-tracker-2.0-0.7.rc1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c8d09c09ea
Comment 9 Fedora Update System 2016-03-15 14:50:14 EDT
hamster-time-tracker-2.0-0.7.rc1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1b469d9a2d
Comment 10 Fedora Update System 2016-03-15 15:22:19 EDT
hamster-time-tracker-2.0-0.7.rc1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-211cb25c0d
Comment 11 Fedora Update System 2016-03-21 15:55:12 EDT
hamster-time-tracker-2.0-0.8.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-27b68e1fe5
Comment 12 Fedora Update System 2016-03-22 17:26:22 EDT
hamster-time-tracker-2.0-0.8.rc1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-27b68e1fe5
Comment 13 Fedora Update System 2016-03-22 17:40:36 EDT
hamster-time-tracker-2.0-0.7.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c8d09c09ea
Comment 14 Fedora Update System 2016-03-23 18:27:31 EDT
hamster-time-tracker-2.0-0.7.rc1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2016-03-25 09:30:41 EDT
hamster-time-tracker-2.0-0.8.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-27b68e1fe5
Comment 16 Fedora Update System 2016-03-25 19:48:38 EDT
hamster-time-tracker-2.0-0.8.rc1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-27b68e1fe5
Comment 17 Fedora Update System 2016-03-26 14:10:42 EDT
hamster-time-tracker-2.0-0.7.rc1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2016-04-02 16:18:49 EDT
hamster-time-tracker-2.0-0.8.rc1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.