Bug 131644 - touch: setting times of `my_shares/my_touch_test': Input/output error
touch: setting times of `my_shares/my_touch_test': Input/output error
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-02 15:58 EDT by John Steinman
Modified: 2015-01-04 17:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:30:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smb.conf file (10.46 KB, text/plain)
2004-09-03 07:16 EDT, John Steinman
no flags Details
smb.conf file (10.46 KB, text/plain)
2004-09-03 07:18 EDT, John Steinman
no flags Details

  None (edit)
Description John Steinman 2004-09-02 15:58:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
Linux litehouse 2.6.8-1.521 #1 Mon Aug 16 09:01:18 EDT 2004 i686 i686
i386 GNU/Linux

samba-client-3.0.6-2.fc2
system-config-samba-1.2.9-2
samba-common-3.0.6-2.fc2
samba-3.0.6-2.fc2

# mount -t smb -o uid=1562,gid=501,rw,username=steinman //anw/steinman
/home/steinman/my_shares

Password:

The shares mount and I can do an "ls"

> ls my_shares/
bin   Mail  ns_imap         Paks    public_html      sandboxes   tmp 
    working
JAGS  Mwm   ODE_client.log  public  public_html_old  test_touch  WINDOWS

> touch my_shares/my_touch_test
touch: setting times of `my_shares/my_touch_test': Input/output error

After this I can't do anything to this mount point:

> ls my_shares/
ls: my_shares/: Input/output error

# umount /home/steinman/my_shares
umount: /home/steinman/my_shares: device is busy
umount: /home/steinman/my_shares: device is busy

This worked until I upgraded from FC1 to FC2.

The only way I can clear this condition this to reboot.

Version-Release number of selected component (if applicable):
samba-3.0.6-2.fc2

How reproducible:
Always

Steps to Reproduce:
1. mount shares from server
2. get a directory of the shares mount point "ls"
3. attempt to touch a file on shares mount point "touch"
    

Actual Results:  touch: setting times of `my_shares/my_touch_test':
Input/output error

From this point on the point point is hosed.

Expected Results:  I should have read/write access to my shares.

Additional info: I have another system that is still running FC1 that
can still mount this share. This is not a server problem.
Comment 1 David Lawrence 2004-09-02 16:11:26 EDT
We will need to see a copy of your smb.conf from the samba server side
for more information.
Comment 2 Jay Fenlason 2004-09-02 16:12:35 EDT
You are using the smbfs module to mount a remote SMB filesystem.   
Any problems after the mount succeeds are not Samba's problem.   
They're a bug in the Linux kernel module.  I'm reassigning this bug  
to the kernel.  
  
Have you tried using the "cifs" kernel module instead?  It is more  
reliable than the "smbfs" module, and has an active maintainer.  To  
use it, specify "-t cifs" instead of "-t smb" on your mount line.   
"man mount.cifs" will describe all the options you can pass to it--I  
think they may be different from what mount.smb wants. 
Comment 3 John Steinman 2004-09-03 07:16:45 EDT
Created attachment 103428 [details]
smb.conf file

David I have attached the smb.conf file to the case.
Comment 4 John Steinman 2004-09-03 07:18:39 EDT
Created attachment 103429 [details]
smb.conf file

David I have attached the smb.conf file to the case.
Comment 5 John Steinman 2004-09-03 07:21:09 EDT
Jay, thanks for the suggestion to use "cifs" I'll give it a try. 
Comment 6 John Steinman 2004-09-06 07:15:06 EDT
Jay, I tried the "cifs" mount on my FC2 system and got the following
error:

# mount -t cifs -o uid=1562,gid=501,rw,username=steinman
//anw/steinman /home/steinman/my_shares
Password: 
mount error 13 = Permission denied

I have tried this on my FC1 system but the kernel doesn't appear to be
configured to support it. I'll need to add it to the FC1 kernel to
test it.
Comment 7 John Steinman 2004-09-06 07:48:56 EDT
Jay, My FC1 system:

# uname -a 
Linux monza 2.4.22-1.2197.nptl #1 Thu Jul 1 15:28:56 EDT 2004 i686
athlon i386 GNU/Linux

has a manpage for mount.cifs but I can not find any supporting bits in
the kernel sources or in the confiuration file. 

Am I missing something or was it not supported under 2.4.x?

Here the error I get when I attempted to mount using "cifs" on FC1:

# mount -t cifs -o uid=1562,gid=501,rw,username=steinman
//anw/steinman /home/steinman/my_shares
Password: 
mount error: cifs filesystem not supported by the system
Comment 8 John Steinman 2004-09-06 08:18:47 EDT
Dave,

I just realized you asked for the server side smb.conf file. I do not
have access (root privs) to that file on the server. The server is a
Tru64 UNIX system running ASU "Advanced Server for UNIX" as the file
shares application. It appear to support both SAMBA and Windows shares
and has been working up to this point under 2.4.x systems. It appears
that the problem just started under the 2.6.x kernel.

Comment 9 Dave Jones 2005-04-16 00:30:51 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.