Bug 1316458 - Upgrade from 6.1.7 to 6.2 Snap 3 is failing with dependencies
Upgrade from 6.1.7 to 6.2 Snap 3 is failing with dependencies
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: Eric Helms
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 05:06 EST by Jitendra Yejare
Modified: 2016-05-21 04:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-21 04:36:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs attached (393.80 KB, text/plain)
2016-03-10 05:06 EST, Jitendra Yejare
no flags Details
yum update sat packages with rhscl repo enable fails with same issue (73.74 KB, text/plain)
2016-03-16 06:09 EDT, Jitendra Yejare
no flags Details

  None (edit)
Description Jitendra Yejare 2016-03-10 05:06:25 EST
Created attachment 1134779 [details]
Logs attached

Description of problem:
Satellite Upgrade from 6.1 to 6.2 snap 3 is failing with dependencies during yum update satellite packages from latest compose.

Version-Release number of selected component (if applicable):
Satellite 6.2 snap 3

How reproducible:
Always

Steps to Reproduce:
1. Start upgrading Satellite from 6.1 to 6.2.
2. yum update os packages on satellite first.
3. Disable satellite 6.1 repo on satellite.
4. Set latest compose repo in /etc/yum.rpeos.d/sat6.repo
5. Stop services, except Mongo.
6. yum clean all.
7. yum update satellite packages.
# yum update -y

Actual results:
yum update failed with dependencies issue.

Output from Satellite on rhle7:
http://pastebin.com/b6YeZiPJ
Also attached to bug.

Expected results:
No failure/dependencies errors in yum updating packages while upgrading from 6.1 to 6.2.

Additional info:
Comment 2 Eric Helms 2016-03-10 12:27:08 EST
Can you provide a yum repolist? Based on your steps provided, my guess is that you are missing the proper RHSCL repo updates needed.
Comment 3 Jitendra Yejare 2016-03-14 05:36:27 EDT
Hi Eric,

Yeah, I am completely disabling RHSCL repo.

Only 'rhel-7-server-rpms' and sat6.repo(latest compose repo) are enabled.

So Do you recommand to enable RHSCL repo while upgrading to 6.2. Because we are not enabling this repo while upgrading to 6.1 from 6.0 or any 6.1.z.


Thanks,
Jitendra
Comment 4 Jitendra Yejare 2016-03-14 09:47:13 EDT
Comment 3 ?
Comment 5 Eric Helms 2016-03-14 11:16:10 EDT
I am admittedly confused how an upgrade ever worked with RHSCL since that is a core dependency and has been for many releases. That being said, you absolutely need RHSCL for Satellite to work.
Comment 6 Jitendra Yejare 2016-03-16 06:06:36 EDT
@Eric,

I have enabled RHSCL repo(rhel-server-rhscl-7-rpms) and retried but still I see yum update satellite packages is failing with the dependency issues.

I am attaching new logs. Please find the same.
Comment 7 Jitendra Yejare 2016-03-16 06:09 EDT
Created attachment 1136948 [details]
yum update sat packages with rhscl repo enable fails with same issue
Comment 10 Jitendra Yejare 2016-05-20 02:40:23 EDT
@BK:
I think we are not getting any more dependency errors while upgrading from 6.1 to 6.2 snap 11. We can close this. Still I will let Sachin to take decision on this.
Comment 11 Sachin Ghai 2016-05-21 04:36:47 EDT
Yeah.. this can be closed now. we are no longer facing any dependency issue while performing upgrade from sat6.1.9 -> sat6.2 snap12.

Note You need to log in before you can comment on or make changes to this bug.