Bug 1316462 - Fix possible failure in tests/basic/afr/arbiter.t
Fix possible failure in tests/basic/afr/arbiter.t
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: arbiter (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
:
Depends On:
Blocks: 1317391
  Show dependency treegraph
 
Reported: 2016-03-10 05:19 EST by Ravishankar N
Modified: 2016-06-16 09:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1317391 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:59:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2016-03-10 05:19:10 EST
Description of problem:

-----------------------------------------------------------------------
master:https://build.gluster.org/job/rackspace-regression-2GB-triggered/18980/console

/tests/basic/afr/arbiter.t (Wstat: 0 Tests: 54 Failed: 3)
  Failed tests:  26, 29, 52

[root@ravi4 glusterfs]# show-test.sh tests/basic/afr/arbiter.t 26
43 TEST setfattr -n user.name -v value1  $M0/file
[root@ravi4 glusterfs]# show-test.sh tests/basic/afr/arbiter.t 29
48 TEST setfattr -n user.name -v value2  $M0/file
[root@ravi4 glusterfs]# show-test.sh tests/basic/afr/arbiter.t 52
81 TEST getfattr -n user.name $M0/file


-----------------------------------------------------------------------
3.7: https://build.gluster.org/job/rackspace-regression-2GB-triggered/18981/console

./tests/basic/afr/arbiter.t (Wstat: 0 Tests: 50 Failed: 3)
  Failed tests:  22, 25, 48
35 TEST setfattr -n user.name -v value1  $M0/file
[root@ravi4 glusterfs]# show-test.sh tests/basic/afr/arbiter.t 25
40 TEST setfattr -n user.name -v value2  $M0/file
[root@ravi4 glusterfs]# show-test.sh tests/basic/afr/arbiter.t 48
73 TEST getfattr -n user.name $M0/file
Comment 1 Vijay Bellur 2016-03-10 05:24:50 EST
REVIEW: http://review.gluster.org/13667 (afr: Add more checks to check bricks being up) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 2 Ravishankar N 2016-03-10 07:39:41 EST
Just for the record: http://www.gluster.org/pipermail/gluster-devel/2016-March/048679.html
Comment 3 Vijay Bellur 2016-03-14 04:14:54 EDT
COMMIT: http://review.gluster.org/13667 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit e04bc451912733ab12bac28e47b4dd892df667d9
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Thu Mar 10 15:53:23 2016 +0530

    afr: Add more checks to check bricks being up
    
    Change-Id: I27f1a1c2f28d129ef7fafc676a8d3d6b82bcf2e4
    BUG: 1316462
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/13667
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 4 Niels de Vos 2016-06-16 09:59:45 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.