Bug 1316480 - OData - $skip is beeing ignored
OData - $skip is beeing ignored
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.3.0
Assigned To: Van Halbert
Juraj Duráni
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 06:00 EST by Juraj Duráni
Modified: 2016-08-24 07:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 07:48:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-4046 Major Closed OData - $skip is beeing ignored 2016-06-05 19:43 EDT

  None (edit)
Description Juraj Duráni 2016-03-10 06:00:47 EST
Description of problem:
Query option $skip should accept non-negative integers but this option seems to be ignored by Teiid. Note, negative integer should cause error (i.e status code 400).

http://localhost:8080/odata4/olingo_basic/Source/Customers/?$skip=3

See http://docs.oasis-open.org/odata/odata/v4.0/errata02/os/complete/part1-protocol/odata-v4.0-errata02-os-part1-protocol-complete.html#_Toc406398307
Comment 1 JBoss JIRA Server 2016-03-10 19:47:33 EST
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-4046 to Resolved
Comment 2 JBoss JIRA Server 2016-06-05 19:43:59 EDT
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-4046 to Closed

Note You need to log in before you can comment on or make changes to this bug.