Bug 1316484 - OData - $top with negative value return status code 500
OData - $top with negative value return status code 500
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.3.0
Assigned To: Van Halbert
Juraj Duráni
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 06:02 EST by Juraj Duráni
Modified: 2016-08-24 07:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 07:36:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-4047 Major Closed OData - $top with negative value return status code 500 2016-06-15 08:36 EDT

  None (edit)
Description Juraj Duráni 2016-03-10 06:02:03 EST
Description of problem:
OData request with query option $top with negative value returns status code 500. The root cause is SQLException. OData service should check passed value and return e.g. 400 instead.

*URL:* http://localhost:8080/odata4/olingo_basic/Source/Customers/?$top=-1

See http://docs.oasis-open.org/odata/odata/v4.0/errata02/os/complete/part1-protocol/odata-v4.0-errata02-os-part1-protocol-complete.html#_Toc406398306
Comment 1 JBoss JIRA Server 2016-03-14 09:07:19 EDT
Ramesh Reddy <rareddy@jboss.org> updated the status of jira TEIID-4047 to Coding In Progress
Comment 2 JBoss JIRA Server 2016-03-17 10:17:28 EDT
Ramesh Reddy <rareddy@jboss.org> updated the status of jira TEIID-4047 to Resolved
Comment 3 Juraj Duráni 2016-05-25 09:17:40 EDT
Teiid returns reasonable error message. Verified.
Comment 4 JBoss JIRA Server 2016-06-15 08:36:06 EDT
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-4047 to Closed

Note You need to log in before you can comment on or make changes to this bug.