Bug 1316487 - virt-v2v: error: libguestfs error: file receive cancelled by daemon when about 100M space left on host while conversion
virt-v2v: error: libguestfs error: file receive cancelled by daemon when abou...
Status: CLOSED DUPLICATE of bug 1316479
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.3
x86_64 Unspecified
high Severity high
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
V2V
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 06:04 EST by mxie@redhat.com
Modified: 2016-06-23 08:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 08:00:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot-116M (62.58 KB, image/png)
2016-03-10 06:04 EST, mxie@redhat.com
no flags Details
virt-v2v-xen-kvm-log (74.92 KB, text/plain)
2016-03-10 06:05 EST, mxie@redhat.com
no flags Details
virt-v2v-xen-rhev-log (71.34 KB, text/plain)
2016-03-10 06:05 EST, mxie@redhat.com
no flags Details

  None (edit)
Description mxie@redhat.com 2016-03-10 06:04:03 EST
Created attachment 1134814 [details]
screenshot-116M

Description of problem:
virt-v2v: error: libguestfs error: file receive cancelled by daemon when about 100M space left on host while conversion


Version-Release number of selected component (if applicable):
libvirt-1.2.17-13.el7_2.4.x86_64
kernel-3.10.0-229.29.1.el7
qemu-kvm-1.5.3-105.el7_2.3.x86_64
libguestfs-winsupport-7.2-1.el7.x86_64
virtio-win-1.8.0-4.el7.noarch
virt-v2v-1.28.1-1.55.el7_2.1.x86_64
libguestfs-1.28.1-1.55.el7_2.1.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Make about 100M space left on host, please see "screenshot-116M"

2.Convert guest from xen to local, the error shows as below, details please refer to log"virt-v2v-xen-kvm.log"
1.# virt-v2v -ic xen+ssh://10.66.106.64 -b virbr0 xen-rhel7.2-mxie -on mm -of raw
[   0.0] Opening the source -i libvirt -ic xen+ssh://10.66.106.64 xen-rhel7.2-mxie
[   0.0] Creating an overlay to protect the source from being modified
[   1.0] Opening the overlay
[   7.0] Initializing the target -o libvirt -os default
[   7.0] Inspecting the overlay
virt-v2v: error: libguestfs error: file receive cancelled by daemon

If reporting bugs, run virt-v2v with debugging enabled and include the
complete output:

  virt-v2v -v -x [...]

3.Convert guest from xen to rhev, the error shows as below, details please refer to log"virt-v2v-xen-rhev.log"
# virt-v2v -ic xen+ssh://10.66.106.64 -o rhev -os 10.73.72.63:/home/nfs_export -n ovirtmgmt -b ovirtmgmt xen-rhel7.2-mxie -of raw
[   0.0] Opening the source -i libvirt -ic xen+ssh://10.66.106.64 xen-rhel7.2-mxie
[   0.0] Creating an overlay to protect the source from being modified
[   1.0] Opening the overlay
[   7.0] Initializing the target -o rhev -os 10.73.72.63:/home/nfs_export
[   7.0] Inspecting the overlay
virt-v2v: error: libguestfs error: file receive cancelled by daemon

If reporting bugs, run virt-v2v with debugging enabled and include the
complete output:

  virt-v2v -v -x [...]


Actual results:
As above description

Expected results:
Should report the error like below:
qemu-img: /var/tmp/v2vovl7dab64.qcow2: Could not write qcow2 header: No space left on device
virt-v2v: error: qemu-img command failed, see earlier errors


Addtional info:
Comment 2 mxie@redhat.com 2016-03-10 06:05 EST
Created attachment 1134815 [details]
virt-v2v-xen-kvm-log
Comment 3 mxie@redhat.com 2016-03-10 06:05 EST
Created attachment 1134816 [details]
virt-v2v-xen-rhev-log
Comment 4 Richard W.M. Jones 2016-06-23 08:00:34 EDT

*** This bug has been marked as a duplicate of bug 1316479 ***

Note You need to log in before you can comment on or make changes to this bug.