Bug 1316499 - volume set on user.* domain trims all white spaces in the value
volume set on user.* domain trims all white spaces in the value
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Atin Mukherjee
: Triaged
Depends On:
Blocks: 1320821
  Show dependency treegraph
 
Reported: 2016-03-10 06:16 EST by Atin Mukherjee
Modified: 2016-06-16 09:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1320821 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:59:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atin Mukherjee 2016-03-10 06:16:31 EST
Description of problem:
On executing gluster volume set <volname> user.metadata "abc xyz" gluster volume info shows user.metadata as "abcxyz"

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always


Actual results:
user.metadata as "abcxyz"

Expected results:
user.metadata as "abc xyz"
Comment 1 Vijay Bellur 2016-03-10 06:17:12 EST
REVIEW: http://review.gluster.org/13669 (cli: Do not remove whitespace if key is user.* in volume set) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 2 Vijay Bellur 2016-03-24 00:10:14 EDT
COMMIT: http://review.gluster.org/13669 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit f2d51d6546976731fed5fd165bf57acac3fb0180
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Mar 10 16:43:08 2016 +0530

    cli: Do not remove whitespace if key is user.* in volume set
    
    setting any user.* option can have multiple words in the key and hence skip the
    process of trimming whitespaces.
    
    Change-Id: Ia295428d7cda55e5470fef668325bea497f2333d
    BUG: 1316499
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/13669
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:59:45 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.