Bug 1316506 - [RDO Mitaka3 test day] Packstack is not aware of new puppet-cinder changes
[RDO Mitaka3 test day] Packstack is not aware of new puppet-cinder changes
Status: CLOSED WORKSFORME
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Kilo
Assigned To: Martin Magr
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 06:21 EST by Martin Magr
Modified: 2016-04-18 03:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-22 05:41:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Magr 2016-03-10 06:21:48 EST
Description of problem:
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: fd00::1b16_keystone.pp
Error: Invalid parameter public_address on Class[Cinder::Keystone::Auth] at /var/tmp/packstack/c357fc130eda4defaa17ec020ca74cdb/manifests/fd00::1b16_keystone.pp:168 on node test-controller.internal
You will find full trace in log /var/tmp/packstack/20160310-113304-xUmKE_/manifests/fd00::1b16_keystone.pp.log

Version-Release number of selected component (if applicable):
[root@test-controller ~]# rpm -qa openstack*
openstack-puppet-modules-8.0.0a0-0.20160304203011.7dc7e93.el7.centos.noarch
openstack-packstack-puppet-7.0.0-0.12.dev1699.g8f54936.el7.noarch
openstack-packstack-7.0.0-0.12.dev1699.g8f54936.el7.noarch

Additional info:
[root@test-controller ~]# cat /var/tmp/packstack/20160310-113304-xUmKE_/manifests/fd00::1b16_keystone.pp.log
Warning: Scope(Class[Glance::Keystone::Auth]): The public_address parameter is deprecated, use public_url instead.
Warning: Scope(Class[Glance::Keystone::Auth]): The internal_address parameter is deprecated, use internal_url instead.
Warning: Scope(Class[Glance::Keystone::Auth]): The admin_address parameter is deprecated, use admin_url instead.
Error: Invalid parameter public_address on Class[Cinder::Keystone::Auth] at /var/tmp/packstack/c357fc130eda4defaa17ec020ca74cdb/manifests/fd00::1b16_keystone.pp:168 on node test-controller.internal
Wrapped exception:
Invalid parameter public_address
Error: Invalid parameter public_address on Class[Cinder::Keystone::Auth] at /var/tmp/packstack/c357fc130eda4defaa17ec020ca74cdb/manifests/fd00::1b16_keystone.pp:168 on node test-controller.internal
[root@test-controller ~]#
Comment 1 David Moreau Simard 2016-03-21 11:23:41 EDT
Packstack 7 is Liberty and OPM 8 is Mitaka. How did you get that combination ?
Comment 2 Martin Magr 2016-03-21 11:26:58 EDT
For some reason packstack from delorean-deps.repo was installed instead of from delorean.repo and I did not realize that. I should rerun my test case and close all invalid bugs.
Comment 3 Alan Pevec 2016-03-21 19:34:35 EDT
> For some reason packstack from delorean-deps.repo was installed instead of
> from delorean.repo

That happens when priorities are not taken into account: .repo files have priority set but it's not active until yum-plugin-priorities RPM is installed.
Comment 4 Martin Magr 2016-03-22 05:41:00 EDT
Works for me with below version.

openstack-packstack-8.0.0-0.20160321212000.5939a9f.el7.centos.noarch

Note You need to log in before you can comment on or make changes to this bug.