Bug 1316514 - SELinux is preventing colord from 'read' accesses on the file /etc/udev/hwdb.bin.
SELinux is preventing colord from 'read' accesses on the file /etc/udev/hwdb....
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
medium Severity high
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
AcceptedBlocker abrt_hash:559041157b3...
:
: 1317259 (view as bug list)
Depends On:
Blocks: F24FinalBlocker 1324312
  Show dependency treegraph
 
Reported: 2016-03-10 06:45 EST by Vít Ondruch
Modified: 2016-10-07 08:01 EDT (History)
23 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-180.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1324312 (view as bug list)
Environment:
Last Closed: 2016-05-16 13:48:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2016-03-10 06:45:47 EST
Description of problem:
SELinux is preventing colord from 'read' accesses on the file /etc/udev/hwdb.bin.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that colord should be allowed read access on the hwdb.bin file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep colord /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:colord_t:s0
Target Context                unconfined_u:object_r:systemd_hwdb_etc_t:s0
Target Objects                /etc/udev/hwdb.bin [ file ]
Source                        colord
Source Path                   colord
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           systemd-udev-229-5.fc25.x86_64
Policy RPM                    selinux-policy-3.13.1-177.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.4.0-1.fc24.x86_64 #1 SMP Mon Jan
                              11 16:48:24 UTC 2016 x86_64 x86_64
Alert Count                   2
First Seen                    2016-03-10 12:44:22 CET
Last Seen                     2016-03-10 12:44:22 CET
Local ID                      3418d193-6e35-4662-aeb8-99f12f702fb0

Raw Audit Messages
type=AVC msg=audit(1457610262.399:299): avc:  denied  { read } for  pid=1806 comm="colord" name="hwdb.bin" dev="dm-1" ino=2099237 scontext=system_u:system_r:colord_t:s0 tcontext=unconfined_u:object_r:systemd_hwdb_etc_t:s0 tclass=file permissive=0


Hash: colord,colord_t,systemd_hwdb_etc_t,file,read

Version-Release number of selected component:
selinux-policy-3.13.1-177.fc25.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.4.0-1.fc24.x86_64
type:           libreport
Comment 1 Lukas Vrabec 2016-03-15 12:21:18 EDT
*** Bug 1317259 has been marked as a duplicate of this bug. ***
Comment 2 Joachim Frieben 2016-03-19 07:12:33 EDT
SELinux alerts are still being triggered during a live session using Fedora 24 Workstation Live Alpha 6 media including selinux-policy-targeted-3.13.1-179.fc24.
Comment 3 Adam Williamson 2016-03-23 02:42:56 EDT
Description of problem:
Booted F24 Alpha candidate 7 (Alpha-1.7) Workstation x86_64 live on bare metal (some yum-cha RCA TV as the monitor, Intel graphics adapter). Denial was visible as soon as I reached the desktop, along with a gnome-settings-daemon crash.

Version-Release number of selected component:
selinux-policy-3.13.1-179.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
type:           libreport
Comment 4 Adam Williamson 2016-03-23 02:59:14 EDT
Proposing as a Final blocker: "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop."
Comment 5 Lukas Vrabec 2016-03-23 07:26:31 EDT
commit e1f0dcee7f7452e12c492648ee9310f867dd8879
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Wed Mar 23 12:25:45 2016 +0100

    Allow colord to read /etc/udev/hwdb.bin. rhzb#1316514
Comment 6 Vedran Miletić 2016-03-24 19:26:49 EDT
Description of problem:
Logged in to GNOME desktop

Version-Release number of selected component:
selinux-policy-3.13.1-179.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-300.fc24.x86_64
type:           libreport
Comment 7 satellitgo 2016-03-24 19:34:49 EDT
Description of problem:
efi boot of f24 alpha 7 workstation dd USB

Version-Release number of selected component:
selinux-policy-3.13.1-179.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
type:           libreport
Comment 8 Dan Mossor [danofsatx] 2016-03-29 12:58:40 EDT
+1 Blocker. Should be no AVCs in released product.
Comment 9 Kamil Páral 2016-03-29 13:24:49 EDT
Discussed at today's blocker review meeting [1]. Voted as AcceptedBlocker (Final) - clear violation of "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop."

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-29
Comment 10 moon@nntq.net 2016-03-31 09:43:21 EDT
Description of problem:
Installing Fedora 24 Alpha 7 from a USB drive, happens right after boot on the USB stick

Version-Release number of selected component:
selinux-policy-3.13.1-179.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
type:           libreport
Comment 11 Robert Zaragoza 2016-04-21 13:28:30 EDT
Description of problem:
This occurred when attempting to upgrade to Fedora 24 from 23.

Version-Release number of selected component:
selinux-policy-3.13.1-179.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
type:           libreport
Comment 12 Kamil Páral 2016-05-16 13:48:41 EDT
This seems fixed with selinux-policy-3.13.1-180.fc24, please reopen if you see it again with this or newer build.

Note You need to log in before you can comment on or make changes to this bug.