Bug 131653 - bluez-libs-2.10-2 shouldn't Obsoletes: bluez-sdp, -> bluez-utils instead
bluez-libs-2.10-2 shouldn't Obsoletes: bluez-sdp, -> bluez-utils instead
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bluez-libs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-02 16:57 EDT by Rex Dieter
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 07:17:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2004-09-02 16:57:16 EDT
As the sdp functionality is (apparently) now in the bluez-utils pkg, the
Obsoletes: bluez-sdp
should be in bluez-utils, *not* bluez-libs
Comment 1 David Woodhouse 2004-09-02 17:47:38 EDT
libsdp is in bluez-libs
sdpd is in bluez-utils.

I don't think it makes a lot of difference -- you need both anyway.

Is there any real reason to change it?
Comment 2 Víctor Daniel Velasco Martínez 2004-09-03 01:39:03 EDT
Ok, the problem is when upgrading the bluez-libs package, bluez-sdp  
becomes obsolete... but neither the latest bluez-lib rpm nor  
bluez-utils rpm have spdp anymore... and bluez-sdp doesn't longer  
exist... I think, that according to www.bluez.org, sdpd SHOULD be in  
bluez-utils, but it isn't anywhere... even the init script  
(/etc/init.d/bluetooth), when asked for status, tells that sdpd is  
stopped, and when trying to stop the service, it fails saying that  
sdpd doesn't exist. (btw, this is fc2)  
  
So, IMHO, I think that either a new bluez-sdp package depending in  
the new bluez-libs rpm, or a a new bluez-utils including sdpd should  
fix this problem.  
 
Víctor Daniel Velasco Martínez 
Comment 3 David Woodhouse 2004-09-03 05:15:37 EDT
My copy of bluez-utils-2.10-2 definitely includes /usr/sbin/sdpd.
Could it be that your bluez-utils was installed before your bluez-sdp
was removed, and that /usr/sbin/sdpd was a casualty of that? That
would surprise me, because if rpm was going to be that naïve on
removal then I'd also expect it to complain of conflicts during the
installation of bluez-utils. It's possible though, I suppose. 

How did you upgrade? yum/up2date/installer/rpm...?
Comment 4 Rex Dieter 2004-09-03 08:21:09 EDT
Re: comment #1: My point is bluez-libs shouldn't Obsoletes bluez-sdp
because it really doesn't, nor does it contain the functionality that
bluez-sdp provided.  As pointed out, the sdp functionality is now in
bluez-utils, so *that* package should be the one that does the Obsoletes.
Comment 5 David Woodhouse 2004-09-03 08:57:10 EDT
libbluetooth, which is in bluez-libs, now contains the functionality
(and indeed the functions) which used to be in libsdp.

The old bluez-sdp package is obsoleted by the combination of
bluez-libs and bluez-utils.

This is a packaging problem -- and I'm not entirely sure what caused
the actual problem for you in the first place. Can you explain how you
installed the FC3 rpms on your FC2 system, and I'll get someone with
more rpm-fu to take a look. It's entirely feasible that you're right
and that we should move the Obsoletes: to bluez-utils. I'd just like a
definitive answer, rather than doing it 'in case it helps'.
Comment 6 Rex Dieter 2004-09-03 09:20:16 EDT
> libbluetooth, which is in bluez-libs, now contains the functionality
> (and indeed the functions) which used to be in libsdp.

Victor and I are not talking about libsdp, but about the spd daemon
which was once in bluez-spd (in fc2).  We both got to this point of
missing spd functionality by simply upgrading bluez-libs on an fc2 box.

Victor also pointed out that the latest bluez-utils in FC3??/rawhide
still contain references to /usr/sbin/sdpd even though it apparently
doesn't exist anymore or was accidentally/purposefully omitted.
Comment 7 David Woodhouse 2004-09-03 11:33:35 EDT
The latest bluez-utils in rawhide still contains references to
/usr/sbin/sdpd because it still actually contains /usr/sbin/sdpd.

If you upgraded bluez-libs on your FC2 box then you also need to
update bluez-utils to match.

Comment 8 Rex Dieter 2004-09-03 14:18:55 EDT
OK, here's the full scoop, and what IMO, should be done to fix it.

1.  bluez-libs-devel technically does provide what bluez-sdp-devel 
used to (and in fact, Conflicts with it), so it should contain:
Obsoletes: bluez-sdp-devel
That is as it is now.  No change required.  Good.

2. bluez-libs still should *not* contain
Obsoletes: bluez-sdp
That role/funcionality is now taken by bluez-utils, and that is where 
the Obsoletes should be.

(In retrospect and further investigation, I also don't see any 
missing spd functionality in the latest/rawhide bluez-utils package
(s).  I believe Victor may have been commenting only on FC2's stock 
version).
Comment 9 Víctor Daniel Velasco Martínez 2004-09-05 02:57:40 EDT
Yes, I've only tested FC2 stock version, not FC3 test 1 
 
If you upgraded bluez-libs on your FC2 box then you also need to 
update bluez-utils to match. <-- there's not an updated bluez-utils 
matching bluez-libs, at least, not by updating with apt. 
 
rex kindly remade the packages in kde-redhat, and it doesn't present 
problems anymore. 
 
Víctor Daniel Velasco Martínez 
Comment 10 David Woodhouse 2005-03-02 07:17:14 EST
Fixed (per comment #8) in bluez-{libs,utils}-2.15-1

Note You need to log in before you can comment on or make changes to this bug.