This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1316555 - Mention in doc that satellite services should be stopped before running yum update
Mention in doc that satellite services should be stopped before running yum u...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Kašpárek
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 08:19 EST by Lukáš Hellebrandt
Modified: 2016-04-28 07:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-28 07:16:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
catalina.out (78.35 KB, text/plain)
2016-03-10 08:19 EST, Lukáš Hellebrandt
no flags Details

  None (edit)
Description Lukáš Hellebrandt 2016-03-10 08:19:00 EST
Created attachment 1134892 [details]
catalina.out

Description of problem:
When running yum update with satellite services running, tomcat complains that we are changing things while it is running. (Traceback attached but probably not important.)
This should be mentioned in rhn-upgrade package's upgrade guide, perhaps in part 2) of /etc/sysconfig/rhn/satellite-upgrade/doc/preparations.txt

Version-Release number of selected component (if applicable):
Tested on Sat 5.4.1

How reproducible:
Deterministic

Steps to Reproduce:
1. Have a not-up-to-date satellite, running.
2. yum update
3. cat /var/log/tomcat6/catalina.out

Actual results:
Tracebacks in catalina.out

Expected results:
No tracebacks
Comment 1 Lukáš Hellebrandt 2016-03-10 08:24:17 EST
To clarify: expected result is "No tracebacks because there was an instruction to shut down satellite services in the upgrade docs"
Comment 4 Lukáš Hellebrandt 2016-03-29 05:42:28 EDT
Verified with rhn-upgrade-5.7.0.30-1 , the correct way is now described in preparations.txt.
Comment 6 errata-xmlrpc 2016-04-28 07:16:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0698.html

Note You need to log in before you can comment on or make changes to this bug.