Bug 131656 - X-windows apps will not start after hostname change
X-windows apps will not start after hostname change
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-02 17:21 EDT by Tim Brown
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-06 18:24:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Brown 2004-09-02 17:21:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
New install of FC2 - unable to start any x-windows apps after setting
hostname.  Also receive an error in xorg.o.log 
Error in log:
X: client 17 rejected from local host

If use hostname to set name back to localhost.localdomain applications
start working again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot to GUI (RL5)
2.Open terminal and su - to root
3.run "hostname usa"


Actual Results:  Try to start any xbased app and pointer goes to HG
and nothing happens

Expected Results:  X-app should have started

Additional info:
Comment 1 Mike A. Harris 2005-03-06 18:24:48 EST
X authentication embeds the hostname into the .Xauthority file,
so you can not change the hostname out from under the running
X server by design (or flaw of design if you prefer).  You need
to restart the server or use xauth or xhost.


Note You need to log in before you can comment on or make changes to this bug.