Bug 1316560 - [RFE] remove the plugin support for spice connection
[RFE] remove the plugin support for spice connection
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
4.0.0
Unspecified Unspecified
high Severity medium
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Marek Libra
sefi litmanovich
: FutureFeature
Depends On:
Blocks: 1324885
  Show dependency treegraph
 
Reported: 2016-03-10 08:23 EST by David Blechter
Modified: 2016-08-23 16:33 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Deprecated Functionality
Doc Text:
The Spice plug-in is not supported in Red Hat Virtualization 4.0. The 'Native' spice connection should be used as a replacement. If 'Plugin' is set as the default for Spice connections by user (via engine-config), it is automatically switched to 'Native' by calling engine-setup during upgrade.
Story Points: ---
Clone Of:
: 1324885 (view as bug list)
Environment:
Last Closed: 2016-08-23 16:33:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 55811 master MERGED webadmin: Spice Plugin deprecated in 4.0 2016-04-25 03:06 EDT

  None (edit)
Description David Blechter 2016-03-10 08:23:10 EST
Description of problem:
WE have introduced the native connection and the plan was to remove plugin support. It is a time finally to remove the support of xpi and activex 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
1. Remove "Browser plugin" option from the RHEVM UI
2. Remove the activex from the windows spice client builds

Additional info:
Comment 1 Michal Skrivanek 2016-03-21 06:18:59 EDT
the existing plugin users would be migrated to "native"
Comment 2 Marek Libra 2016-04-08 05:39:56 EDT
Depends on: https://github.com/oVirt/ovirt-site/pull/171
Comment 3 Marek Libra 2016-04-19 04:46:01 EDT
(In reply to Marek Libra from comment #2)
> Depends on: https://github.com/oVirt/ovirt-site/pull/171

Merged
Comment 4 Marek Libra 2016-04-27 03:03:25 EDT
The Spice plugin is hidden in the 4.0 UI, but it remains in 4.0 code base and will be removed in 4.1.

Following workaround re-enables the plugin in the UI to fix potential issues in production (will not be valid in 4.1):
  ENGINE_DB: set vdc_options.EnableDeprecatedClientModeSpicePlugin to 'true'

Since deprecation of this feature, users are strongly advised to move to 'Native' from 'Plugin' and avoid using this workaround.
Comment 6 David Blechter 2016-05-05 15:52:55 EDT
(In reply to Marek Libra from comment #4)
> The Spice plugin is hidden in the 4.0 UI, but it remains in 4.0 code base
> and will be removed in 4.1.
> 
> Following workaround re-enables the plugin in the UI to fix potential issues
> in production (will not be valid in 4.1):
>   ENGINE_DB: set vdc_options.EnableDeprecatedClientModeSpicePlugin to 'true'
> 
> Since deprecation of this feature, users are strongly advised to move to
> 'Native' from 'Plugin' and avoid using this workaround.

The 4.0 is the right place, and we are removing cab rpm from the windows client builds started from 4.0. Even the code exists, we should make this option unavailable for the users.
Comment 7 Michal Skrivanek 2016-06-01 10:06:40 EDT
probably in the current build
Comment 8 sefi litmanovich 2016-07-27 08:57:12 EDT
Verified with rhevm-4.0.2-0.1.rc.el7ev.noarch.
Browser plugin option is removed from 'console invocations' section of console options menu of a vm with spice, and default is set to native.
Also verified the W/A which allows to change the value of 'EnableDeprecatedClientModeSpicePlugin' to 'true' in vdc_options in order to restore the plugin option.
Comment 10 errata-xmlrpc 2016-08-23 16:33:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html

Note You need to log in before you can comment on or make changes to this bug.