Bug 1316570 - "Project Explorer" pane redraws text on scrolling in a manner that ..
"Project Explorer" pane redraws text on scrolling in a manner that ..
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 08:58 EST by lejeczek
Modified: 2016-03-15 05:59 EDT (History)
7 users (show)

See Also:
Fixed In Version: eclipse-4.5.2-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-15 05:38:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lejeczek 2016-03-10 08:58:27 EST
Description of problem:

... list of files/folder becomes uneasy to follow, sort of a bold text, does it erratically, does not matter which perspective you are in.

Version-Release number of selected component (if applicable):

eclipse-platform-4.5.1-12.fc23.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Mat Booth 2016-03-10 09:36:43 EST
eclipse-platform 4.5.2 (Mars.2) is currently in updates-testing, can you confirm that the issue is still present in the latest version?

https://bodhi.fedoraproject.org/updates/FEDORA-2016-159206ccc7

You can test packages from updates-testing by doing, for example:

$ sudo dnf --enablerepo=updates-testing update eclipse-platform
Comment 2 lejeczek 2016-03-14 11:46:47 EDT
I'm during a process of updating to Mars.2 and I hit this:

Cannot complete the install because one or more required items could not be found.
  Software being installed: C/C++ IBM XLC Compiler Support Source 8.8.0.201602041658 (org.eclipse.cdt.xlc.source.feature.group 8.8.0.201602041658)
  Missing requirement: C/C++ IBM XLC Compiler Support Source 8.8.0.201602041658 (org.eclipse.cdt.xlc.source.feature.group 8.8.0.201602041658) requires 'org.eclipse.cdt.errorparsers.xlc.source [5.0.100.201602041658]' but it could not be found

but installation seems to successfully complete migration.
I restart my Eclipse and... yes! hurray, that left pane while scrolled looks ok.
thanks
Comment 3 Mat Booth 2016-03-15 05:38:26 EDT
(In reply to lejeczek from comment #2)
> I'm during a process of updating to Mars.2 and I hit this:
> 
> Cannot complete the install because one or more required items could not be
> found.
>   Software being installed: C/C++ IBM XLC Compiler Support Source
> 8.8.0.201602041658 (org.eclipse.cdt.xlc.source.feature.group
> 8.8.0.201602041658)
>   Missing requirement: C/C++ IBM XLC Compiler Support Source
> 8.8.0.201602041658 (org.eclipse.cdt.xlc.source.feature.group
> 8.8.0.201602041658) requires 'org.eclipse.cdt.errorparsers.xlc.source
> [5.0.100.201602041658]' but it could not be found
> 

It's probably worth noting that there are CDT updates also available in updates-testing.

> but installation seems to successfully complete migration.
> I restart my Eclipse and... yes! hurray, that left pane while scrolled looks
> ok.
> thanks

Great, thanks for testing. I will mark this bug as fixed in Mars.2.
Comment 4 lejeczek 2016-03-15 05:59:53 EDT
I don't know, hmm... I did update eclipse*

Note You need to log in before you can comment on or make changes to this bug.