This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1316592 - AvailableConnections remains empty for bond
AvailableConnections remains empty for bond
Status: CLOSED DUPLICATE of bug 1316488
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 09:47 EST by Marius Vollmer
Modified: 2016-03-15 13:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-15 13:02:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Vollmer 2016-03-10 09:47:24 EST
(Probably related to bug 1316488.)
 
Description of problem:
After creating a new bond, the AvailableConnections property of the new device remains empty.  This means that Cockpit does not find the slave connections for the bridge, and doesn't show the slave interfaces correctly.

AvailableConnections seems to have the wrong value a lot, and that causes trouble in general for Cockpit.  If AvailableConnections is not reliable, we would have to match connections with devices ourselves, which would suck of course.

Version-Release number of selected component (if applicable):
NetworkManager-1.2.0-0.6.beta2.fc24.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Get to a clean setup with one extra network interface

# nmcli device 
DEVICE  TYPE      STATE         CONNECTION         
ens3    ethernet  connected     Wired connection 1 
ens9    ethernet  disconnected  --                 
lo      loopback  unmanaged     --                

# nmcli connection 
NAME                UUID                                  TYPE            DEVICE 
Wired connection 1  5845fe78-e280-43be-9839-9a0c76317aa0  802-3-ethernet  ens3   


2.  Create a bond by creating two new connection settings

# nmcli connection add type bond con-name BOND
# nmcli connection add type bond-slave con-name ens9 master BOND ifname ens9

# nmcli device show nm-bond

3. Check the AvailableConnections property

# gdbus introspect -y -d org.freedesktop.NetworkManager -o /org/freedesktop/NetworkManager/Devices/3

Actual results:
      readonly ao AvailableConnections = [];


Expected results:
      readonly ao AvailableConnections = [ path-to-BOND-connection-settings ];
Comment 1 Beniamino Galvani 2016-03-15 13:02:59 EDT

*** This bug has been marked as a duplicate of bug 1316488 ***

Note You need to log in before you can comment on or make changes to this bug.