Bug 1316594 - [RFE][swift] Put part-replicas where they go
[RFE][swift] Put part-replicas where they go
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-swift (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity unspecified
: ga
: 9.0 (Mitaka)
Assigned To: Pete Zaitcev
Mike Abrams
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 09:48 EST by Sean Cohen
Modified: 2016-08-11 08:14 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-swift-2.7.0-2.el7ost
Doc Type: Enhancement
Doc Text:
This enhancement adds improved replica placement, and protection from duplicated assignments. This was added because, in the traditional Swift layout, the act of accidentally assigning two replicas of a partition to the same device resulted in a silent reduction of durability. As a result, duplicate assignments are prevented, thereby adhering to calculated guarantees. However, since this requires the number of devices to be no less than the number of replicas, it is possible for certain incorrect old rings to be considered invalid. Consequently, it is still possible to have the number of zones be smaller than the number of replicas.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 08:14:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 241571 None None None 2016-03-10 09:48 EST

  None (edit)
Description Sean Cohen 2016-03-10 09:48:39 EST
Deal with unduplicate device part replica assignment in Swift

See also validate against duplicate device part replica assignment https://review.openstack.org/#/c/222799/
Comment 2 Mike McCune 2016-03-28 19:47:57 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 9 errata-xmlrpc 2016-08-11 08:14:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1597.html

Note You need to log in before you can comment on or make changes to this bug.