Bug 1316600 - change project membership requires another reload to apply
change project membership requires another reload to apply
Status: CLOSED DUPLICATE of bug 1259626
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Itxaka
Ido Ovadia
: ZStream
Depends On: 1344219 1344677
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 09:59 EST by Martin Pavlásek
Modified: 2016-06-22 05:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-22 05:51:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
behaving correctly (1.02 MB, application/ogg)
2016-06-06 12:52 EDT, Itxaka
no flags Details
bug-screencast-doesnt-work.ogv (6.10 MB, application/ogg)
2016-06-21 08:44 EDT, Martin Pavlásek
no flags Details

  None (edit)
Description Martin Pavlásek 2016-03-10 09:59:13 EST
Description of problem:
User can't change project just after project membership assignment.

Version-Release number of selected component (if applicable):
RHEL 7.2
openstack-dashboard-8.0.1-1.el7ost.noarch
python-django-horizon-8.0.1-1.el7ost.noarch
openstack-packstack-puppet-7.0.0-0.12.dev1699.g8f54936.el7ost.noarch
openstack-packstack-7.0.0-0.12.dev1699.g8f54936.el7ost.noarch

How reproducible:
2/2

Steps to Reproduce:
1. assume two users and two projects: admin, demo
2. log in as admin user
3. navigate to Identity - Identity - Projects
4. click to Manage members for 'demo' project
5. add 'admin' user as Project member with role "_member_' (this role is assigned by default)
6. wait until green Success message will appear
7. click to drop-down 'Project' on topbar

Actual results:
Just 'admin'


Expected results:
'admin' and 'demo'

Workaround:
Reload the page until Project drop-down menu will be updated.
Comment 2 Itxaka 2016-04-07 10:49:50 EDT
I am unable to reproduce this on rhos8. I believe this was fixed upstream with a series of patches to doa and horizon to remove the caching of projects like this one: https://github.com/openstack/horizon/commit/fa47798f38b2a58514b93b6613129b0dfca18f36

Im not sure if openstack-dashboard-8.0.1-1.el7ost.noarch is the latest release of horizon, Im gonna check with Matthias and do some more tests to try to reproduce it locally.
Comment 3 Itxaka 2016-04-18 05:12:45 EDT
Can we get the version of python-django-openstack-auth?
Comment 4 Martin Pavlásek 2016-05-02 07:19:59 EDT
Sure, here it is:
python-django-openstack-auth-2.0.1-1.2.el7ost.noarch
Comment 5 Itxaka 2016-05-13 06:51:41 EDT
python-django-horizon-8.0.1-2.el7ost should be available, can you update and try to reproduce it with that version please?


Thanks!
Comment 6 Itxaka 2016-05-13 06:51:42 EDT
python-django-horizon-8.0.1-2.el7ost should be available, can you update and try to reproduce it with that version please?


Thanks!
Comment 7 Martin Pavlásek 2016-05-23 07:10:21 EDT
Thank you, I'll do that as soon as I can.
Comment 8 Martin Pavlásek 2016-05-24 10:43:35 EDT
Hmm.. it works if I add 'admin' to '__member__' role, but I've tried to remove this role back and it doesn't work. I still see 'demo' project in dropdown, even if I remove 'admin' user from membership completely, so this still doesn't work.

Tested on: python-django-horizon-8.0.1-2.el7ost.noarch (so same, as Itxaka mentioned)
Comment 9 Itxaka 2016-06-06 12:35:15 EDT
Weird, I have tried to reproduce this with the same set of versions here and the projects are updated properly.

When adding -> it shows the proper project added to the list
When removed -> removes the project from the list.


Ill attach a small video.
Comment 10 Itxaka 2016-06-06 12:52 EDT
Created attachment 1165305 [details]
behaving correctly
Comment 11 Itxaka 2016-06-06 12:53:28 EDT
Any special thing about this environment that could lead to this discrepancy?
Comment 12 Martin Pavlásek 2016-06-13 05:24:55 EDT
I wanted to reproduce it again, but due problem with packstack installation I can't do that now. Adding the bug as Depends on this bug.
Comment 13 Martin Pavlásek 2016-06-21 08:44 EDT
Created attachment 1170263 [details]
bug-screencast-doesnt-work.ogv

Unfortunately it still doesn't work for me... let's watch attachment bug-screencast-doesnt-work.ogv, especially at 0:27+
Comment 14 Matthias Runge 2016-06-21 13:47:45 EDT
I believe, this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1259626

please report your used version of python-django-openstack-auth
Comment 15 Martin Pavlásek 2016-06-22 05:13:34 EDT
python-django-openstack-auth-2.0.1-1.2.el7ost.noarch
Comment 16 Matthias Runge 2016-06-22 05:15:22 EDT
Ok, please try again with python-django-openstack-auth-2.0.1-3.el7ost
that is the version explicitly listing to fix this kind of issue.
Comment 18 Martin Pavlásek 2016-06-22 05:49:51 EDT
Thanks, I've just tried that with: python-django-openstack-auth-2.0.1-3.el7ost and horizon now behaves correctly.
Comment 19 Matthias Runge 2016-06-22 05:51:22 EDT
Thank you for your comment. Marking this as duplicate.

*** This bug has been marked as a duplicate of bug 1259626 ***

Note You need to log in before you can comment on or make changes to this bug.