Bug 1316607 - [RFE][glance] Image Signing and Verification Support
[RFE][glance] Image Signing and Verification Support
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
unspecified
Unspecified Unspecified
high Severity medium
: ga
: 9.0 (Mitaka)
Assigned To: Flavio Percoco
Avi Avraham
Don Domingo
https://blueprints.launchpad.net/glan...
upstream_milestone_liberty-3 upstream...
: FutureFeature, TechPreview, TestOnly, ZStream
Depends On: 1257306
Blocks: 1342849 1365571
  Show dependency treegraph
 
Reported: 2016-03-10 10:23 EST by Sean Cohen
Modified: 2016-11-07 08:57 EST (History)
15 users (show)

See Also:
Fixed In Version: openstack-glance-12.0.0-1.el7ost
Doc Type: Enhancement
Doc Text:
This update adds support for signing and signature validation of bootable images, and validation of uploaded signed images. If an uploaded image is signed, Glance verifies the signature before storing it, and in cases where the image can be uploaded, the crypto mode and keys must be correctly entered. Authentication protects against counterfeit images and unauthorized images.
Story Points: ---
Clone Of: 1257306
: 1365571 (view as bug list)
Environment:
Last Closed: 2016-08-24 08:53:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2604741 None None None 2016-09-06 10:29 EDT
OpenStack gerrit 177948 None None None 2016-03-10 10:22 EST
OpenStack gerrit 183137 None None None 2016-03-10 10:22 EST

  None (edit)
Comment 2 Mike McCune 2016-03-28 18:37:22 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 15 nlevinki 2016-08-23 02:22:36 EDT
This feature code is partially install on RHOS9, It is missing Barbican ( the store for the keys) and therefore it will not work.
A clone bug was open on RHOS10.
I am moving this bug to verify since the code is in, it is TechPreview.
The verification of this feature moved to RHOS10
Comment 17 errata-xmlrpc 2016-08-24 08:53:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1761.html

Note You need to log in before you can comment on or make changes to this bug.