Bug 1316619 - Q35 support for Windows XP/Windows 2003
Q35 support for Windows XP/Windows 2003
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Laine Stump
Virtualization Bugs
:
Depends On:
Blocks: 1227278
  Show dependency treegraph
 
Reported: 2016-03-10 10:50 EST by Marcel Apfelbaum
Modified: 2016-05-15 14:04 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 959815
Environment:
Last Closed: 2016-03-24 15:44:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Laine Stump 2016-03-24 15:44:54 EDT
My current understanding is that RHEV will require continued support for the 440fx machinetype anyway (in order to maintain existing guests), and it has easy control over which machinetype it uses for which guest OS. Additionally, I don't think there are any Q35-specific features that are required for WinXP/2003, so I think it is safe to say that the path to continued support of WinXP/2003 (for as long as that is desired) will be to use a 440fx machinetype for those guests.

If that's the case, then libvirt needn't do anything, so I'm closing this as WONTFIX. Feel free to re-open if it turns out there really is a requirement to run WinXP on a Q35 machine.

(In the future, when we want Q35 to be the default machinetype for new virtual machines, libosinfo should be enhanced to report a preferred machinetype for a particular OS, but since everything still defaults to Q35 for now, that is something that can be done in the future.)
Comment 3 Laine Stump 2016-05-15 14:04:05 EDT
(I'm not sure why I keep saying "Q35" when I mean "i440fx", but it certainly causes my entire comment to confuse rather than inform :-/.

What I *meant* to say is "since everything still defaults to i440fx for now...".

Note You need to log in before you can comment on or make changes to this bug.