This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1316624 - [abrt] yumex-dnf: misc.py:114:rgb_to_hex:TypeError: %X format: an integer is required, not float
[abrt] yumex-dnf: misc.py:114:rgb_to_hex:TypeError: %X format: an integer is ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
24
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
AcceptedFreezeException abrt_hash:57e...
:
: 1317198 (view as bug list)
Depends On:
Blocks: F24AlphaFreezeException
  Show dependency treegraph
 
Reported: 2016-03-10 11:02 EST by Egor Zaharov
Modified: 2016-03-26 16:20 EDT (History)
7 users (show)

See Also:
Fixed In Version: yumex-dnf-4.1.6-1.fc24 yumex-dnf-4.1.6-1.fc23 yumex-dnf-4.1.6-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-23 11:18:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (878 bytes, text/plain)
2016-03-10 11:03 EST, Egor Zaharov
no flags Details
File: environ (1.44 KB, text/plain)
2016-03-10 11:03 EST, Egor Zaharov
no flags Details

  None (edit)
Description Egor Zaharov 2016-03-10 11:02:59 EST
Description of problem:
Yumex-dnf just crashes after startup in Fedora 24.

If run from cmdline, the output is:

/usr/lib/python3.5/site-packages/yumex/__init__.py:69: Warning: invalid cast from 'GtkBox' to 'GtkWindow'
  self.ui.add_from_file(const.DATA_DIR + '/yumex.ui')

(yumex-dnf:2707): Gtk-CRITICAL **: gtk_window_add_accel_group: assertion 'GTK_IS_WINDOW (window)' failed

(yumex-dnf:2707): Gtk-WARNING **: State 0 for YumexPackageView 0x556256b52be0 doesn't match state 128 set via gtk_style_context_set_state ()
Traceback (most recent call last):
  File "/usr/lib/python3.5/site-packages/yumex/__init__.py", line 1329, in do_command_line
    self.do_activate()
  File "/usr/lib/python3.5/site-packages/yumex/__init__.py", line 1232, in do_activate
    self.win = YumexWindow(self, self.status)
  File "/usr/lib/python3.5/site-packages/yumex/__init__.py", line 401, in __init__
    CONFIG.conf.color_normal = color_to_hex(color_normal)
  File "/usr/lib/python3.5/site-packages/yumex/misc.py", line 118, in color_to_hex
    return rgb_to_hex(color.red, color.green, color.blue)
  File "/usr/lib/python3.5/site-packages/yumex/misc.py", line 114, in rgb_to_hex
    return "#%02X%02X%02X" % (r, g, b)
TypeError: %X format: an integer is required, not float

Version-Release number of selected component:
yumex-dnf-4.1.5-2.fc24

Additional info:
reporter:       libreport-2.6.4
cmdline:        /usr/bin/python3 /usr/bin/yumex-dnf
executable:     /usr/bin/yumex-dnf
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
misc.py:114:rgb_to_hex:TypeError: %X format: an integer is required, not float

Traceback (most recent call last):
  File "/usr/lib/python3.5/site-packages/yumex/__init__.py", line 1329, in do_command_line
    self.do_activate()
  File "/usr/lib/python3.5/site-packages/yumex/__init__.py", line 1232, in do_activate
    self.win = YumexWindow(self, self.status)
  File "/usr/lib/python3.5/site-packages/yumex/__init__.py", line 401, in __init__
    CONFIG.conf.color_normal = color_to_hex(color_normal)
  File "/usr/lib/python3.5/site-packages/yumex/misc.py", line 118, in color_to_hex
    return rgb_to_hex(color.red, color.green, color.blue)
  File "/usr/lib/python3.5/site-packages/yumex/misc.py", line 114, in rgb_to_hex
    return "#%02X%02X%02X" % (r, g, b)
TypeError: %X format: an integer is required, not float

Local variables in innermost frame:
r: 0.0
b: 0.0
g: 0.0
Comment 1 Egor Zaharov 2016-03-10 11:03:03 EST
Created attachment 1134940 [details]
File: backtrace
Comment 2 Egor Zaharov 2016-03-10 11:03:04 EST
Created attachment 1134941 [details]
File: environ
Comment 3 Wolfgang Ulbrich 2016-03-11 11:14:54 EST
Similar problem has been detected:

Using yumex-dnf command from command prompt.
The app crashes and abrt popt up.
Only the icon is visible in mate-panel notification area.
But here only the close button is working.

This is serious, several spins use it as package-manager and we are some weeks before f24 alpha release.

Terminal output:

[rave@mother ~]$ yumex-dnf
/usr/lib/python3.5/site-packages/yumex/__init__.py:69: Warning: invalid cast from 'GtkBox' to 'GtkWindow'
  self.ui.add_from_file(const.DATA_DIR + '/yumex.ui')

(yumex-dnf:17751): Gtk-CRITICAL **: gtk_window_add_accel_group: assertion 'GTK_IS_WINDOW (window)' failed

(yumex-dnf:17751): Gtk-WARNING **: State 0 for YumexPackageView 0x55716b826bd0 doesn't match state 128 set via gtk_style_context_set_state ()
Traceback (most recent call last):
  File "/usr/lib/python3.5/site-packages/yumex/__init__.py", line 1329, in do_command_line
    self.do_activate()
  File "/usr/lib/python3.5/site-packages/yumex/__init__.py", line 1232, in do_activate
    self.win = YumexWindow(self, self.status)
  File "/usr/lib/python3.5/site-packages/yumex/__init__.py", line 401, in __init__
    CONFIG.conf.color_normal = color_to_hex(color_normal)
  File "/usr/lib/python3.5/site-packages/yumex/misc.py", line 118, in color_to_hex
    return rgb_to_hex(color.red, color.green, color.blue)
  File "/usr/lib/python3.5/site-packages/yumex/misc.py", line 114, in rgb_to_hex
    return "#%02X%02X%02X" % (r, g, b)
TypeError: %X format: an integer is required, not float

reporter:       libreport-2.6.4
cmdline:        /usr/bin/python3 /usr/bin/yumex-dnf
event_log:      2016-03-11-17:05:47> (»report_uReport« erfolgreich abgeschlossen)
executable:     /usr/bin/yumex-dnf
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
package:        yumex-dnf-4.1.5-2.fc24
reason:         misc.py:114:rgb_to_hex:TypeError: %X format: an integer is required, not float
runlevel:       N 5
type:           Python3
uid:            1000
Comment 4 Christian Stadelmann 2016-03-12 18:04:00 EST
*** Bug 1317198 has been marked as a duplicate of this bug. ***
Comment 5 eddy02 2016-03-13 04:38:30 EDT
I sent a report for this issue  a few months ago , and the source is corrected.
The git source source works well.
Sorry for my english.
Comment 6 Christian Stadelmann 2016-03-13 07:09:46 EDT
This issue is already fixed in the 4.1.6 release which hasn't landed in Fedora yet.
Comment 7 Fedora Update System 2016-03-17 08:14:48 EDT
yumex-dnf-4.1.6-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2f5cc390c9
Comment 8 Fedora Update System 2016-03-17 08:35:37 EDT
yumex-dnf-4.1.6-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2e89a93119
Comment 9 Fedora Update System 2016-03-17 08:35:52 EDT
yumex-dnf-4.1.6-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-927d14cf42
Comment 10 Fedora Blocker Bugs Application 2016-03-17 10:14:57 EDT
Proposed as a Freeze Exception for 24-alpha by Fedora user raveit65 using the blocker tracking app because:

 Several spins use yumex-dnf as main graphical package-manager.
Without a working yumex-dnf users don't have a GUI for dnf in f24-alpha.
Comment 11 Adam Williamson 2016-03-17 21:00:26 EDT
I'm +1 FE for this if the fix is limited to yumex-dnf (doesn't require changes in e.g. GTK+).
Comment 12 Wolfgang Ulbrich 2016-03-18 06:52:13 EDT
The update works with current gtk+ version and with gtk3-3.19.12-1.fc24.x86_64 which isn't in repos, so it doesn't depends on other packages.
Comment 13 Fedora Update System 2016-03-18 10:57:15 EDT
yumex-dnf-4.1.6-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2f5cc390c9
Comment 14 Dennis Gilmore 2016-03-18 18:14:38 EDT
+1 FE would be good to have it working for those users using it
Comment 15 Kevin Fenzi 2016-03-18 18:15:51 EDT
+1 FE here
Comment 16 Adam Williamson 2016-03-18 18:16:30 EDT
+3, marking accepted.
Comment 17 Fedora Update System 2016-03-18 19:55:35 EDT
yumex-dnf-4.1.6-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-927d14cf42
Comment 18 Fedora Update System 2016-03-18 21:25:55 EDT
yumex-dnf-4.1.6-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2e89a93119
Comment 19 Fedora Update System 2016-03-23 11:17:57 EDT
yumex-dnf-4.1.6-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Egor Zaharov 2016-03-24 17:05:14 EDT
I can confirm, yumex-dnf is working after an update.
Comment 21 eddy02 2016-03-25 04:20:39 EDT
Not working for rawhide , seems to be another bug.

But version 4.3.1 (copr and github)  is ok.
Comment 22 Fedora Update System 2016-03-26 15:49:15 EDT
yumex-dnf-4.1.6-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2016-03-26 16:20:01 EDT
yumex-dnf-4.1.6-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.