Bug 1316632 - The retirement date is off by a day when I retire an VM. [NEEDINFO]
The retirement date is off by a day when I retire an VM.
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.6.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: Martin Hradil
Mike Shriver
ui:vm:retirement
:
: 1419150 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 11:14 EST by Jeff Teehan
Modified: 2017-10-02 10:20 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 09:06:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mhradil: needinfo? (cpelland)


Attachments (Terms of Use)

  None (edit)
Description Jeff Teehan 2016-03-10 11:14:43 EST
Description of problem:
I just set the retirement date on a VM to today.  It retired the VM correctly, but when I look at the summary page for the VM, the date displayed is yesterday.

Version-Release number of selected component (if applicable):
5.6

How reproducible:
At least once.

Steps to Reproduce:
1.  Find a VM and LifeCycle-Set Retirement Date
2.  Pick today from the date widget.
3.  After retirement, check the date field for the retirement date.

Actual results:
Today is 03-10-2016 and the retirement date fields look like this.

Retirement Date	 03/09/16
Retirement state	Retiring

Expected results:


Additional info:

I checked the appliance system date:
[root@10-16-7-137 ~]# date
Thu Mar 10 11:13:50 EST 2016
[root@10-16-7-137 ~]#
Comment 2 Harpreet Kataria 2016-03-11 10:19:29 EST
Martin,

Can you look into this one, it looks like inconsistency between Timezone, when i select date in calendar to today's date, it sends up date-1 in the transaction to server hence incorrect date is getting saved. Let me know if you need help recreating or have questions.

Thanks,
~Harpreet
Comment 5 CFME Bot 2016-09-16 08:40:59 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/298963247759838bd9eeba5cd6ad25cd0620c7eb

commit 298963247759838bd9eeba5cd6ad25cd0620c7eb
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Fri Sep 9 16:46:38 2016 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Fri Sep 16 09:20:39 2016 +0000

    Migrate retires_on and retirement_last_warn to datetime
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1316632

 .../20160912160750_change_retires_on_to_datetime.rb | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
 create mode 100644 db/migrate/20160912160750_change_retires_on_to_datetime.rb
Comment 10 Mike Shriver 2017-04-05 15:22:35 EDT
*** Bug 1419150 has been marked as a duplicate of this bug. ***
Comment 12 Chris Pelland 2017-08-21 09:06:41 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.
Comment 13 Chris Pelland 2017-08-21 09:09:11 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.